Follow us on...
Follow us on Twitter Follow us on Facebook Watch us on YouTube
Reigster at Microsoft Surface Forums
Page 1 of 4 123 ... LastLast
Results 1 to 10 of 37
  1. #1
    Member ltcbob11's Avatar
    Member
    #9499
    Join Date
    Mar 2013
    Posts
    30
    Member #
    9499
    Liked
    1 times

    Surface Pro Firmware Update Issues

    I have downloaded and installed all of the updates, to include the Firmware update. When I look at Device Manager, I see the yellow caution flag under Firmware. Specifically the "Surface Pro System Aggregator Firmware" is flagged. The General tab states that "This device cannot start" .

    A quick look at update history shows that this update failed. Have uninstalled, restarted, etc. no solution.

    Any ideas?

  2. #2
    Junior Member Michael_B's Avatar
    Member
    #9367
    Join Date
    Mar 2013
    Posts
    9
    Member #
    9367
    That's strange... no yellow indicator here. I am showing the driver for that device is v1.4.17232.0

    Nothing odd happened during the update? How many reboots did you have?

  3. #3
    Member ltcbob11's Avatar
    Member
    #9499
    Join Date
    Mar 2013
    Posts
    30
    Member #
    9499
    Liked
    1 times
    Many, many, reboots. No luck.

    Same driver number as you.

  4. #4
    Junior Member Jay Slasher's Avatar
    Member
    #9500
    Join Date
    Mar 2013
    Posts
    29
    Member #
    9500
    Liked
    2 times
    weird, I have the same issue.

  5. #5
    Senior Member HD_Dude's Avatar
    Member
    #9326
    Join Date
    Mar 2013
    Posts
    129
    Member #
    9326
    Liked
    21 times
    This is a tough one.

    So far, half the updates failed - and after a restart it's knocked out my Wedge Mouse....won't work, and it can't find it after I remove it and try to add it again.

    Just tried another restart, and now it's just hanging on the 'restarting' screen....
    Microsoft Surface Pro 128GB - Type Cover - Wedge Mouse Surface Edition - 64 GB San Disk Class 10 Micro SD

  6. #6
    Member ltcbob11's Avatar
    Member
    #9499
    Join Date
    Mar 2013
    Posts
    30
    Member #
    9499
    Liked
    1 times
    Glad I am not the only one. Not that I wish you ill. Lol

  7. #7
    Junior Member cme4oil's Avatar
    Member
    #8510
    Join Date
    Jan 2013
    Posts
    10
    Member #
    8510
    Liked
    1 times
    No problems here. Everything appears to work fine so far. No yellow icons in device manager.

  8. #8
    Senior Member HD_Dude's Avatar
    Member
    #9326
    Join Date
    Mar 2013
    Posts
    129
    Member #
    9326
    Liked
    21 times
    Quote Originally Posted by ltcbob11 View Post
    Glad I am not the only one. Not that I wish you ill. Lol
    Ha...understood.

    Had to hold down the power button until it shut off. I re-installed the mouse OK, and it's going more smoothly now.
    Microsoft Surface Pro 128GB - Type Cover - Wedge Mouse Surface Edition - 64 GB San Disk Class 10 Micro SD

  9. #9
    Junior Member Jay Slasher's Avatar
    Member
    #9500
    Join Date
    Mar 2013
    Posts
    29
    Member #
    9500
    Liked
    2 times
    I still get the warning triangle, however I don't seem to have any noticeable issues... Bluetooth mouse and everything else seems to be working normally.

  10. #10
    Member prscarp's Avatar
    Member
    #9476
    Join Date
    Mar 2013
    Posts
    32
    Member #
    9476
    My Device
    Pro
    Liked
    3 times
    You could try to roll back the device with the error then reboot your PC and check Windows update again. It should redownload the update.

 

 
Page 1 of 4 123 ... LastLast

Ads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Surface PRO Firmware Update...
    By Michael_B in forum Microsoft Surface Pro
    Replies: 50
    Last Post: 03-21-2013, 02:39 AM
  2. Surface Pro issues - day 1
    By jmister in forum Microsoft Surface Pro
    Replies: 13
    Last Post: 02-28-2013, 08:10 AM
  3. Post 12 Feb update stability issues?
    By pwaggs in forum Microsoft Surface General Discussion
    Replies: 7
    Last Post: 02-20-2013, 06:58 PM
  4. Microsoft Sends Out an Update for the Surface RT
    By dgstorm in forum Surface Forum Site News
    Replies: 1
    Last Post: 02-13-2013, 03:26 PM
  5. Jan 8th 2013 - New Firmware released
    By realwarder in forum Microsoft Surface General Discussion
    Replies: 5
    Last Post: 01-08-2013, 07:03 PM

Search tags for this page

surface pro 2 firmware update failed
,
surface pro aggregator firmware
,
surface pro firmware update
,

surface pro firmware update failed

,

surface pro system aggregator firmware

,
surface pro system aggregator firmware code 10
,
surface pro system firmware update failed
,
system firmware update surface pro failed
Click on a term to search for related topics.