kristalsoldier's Recent Activity

  1. kristalsoldier attached a file to the thread Just got the Surface Laptop2.

    ok...now I am having second thoughts about this laptop. Why? Because of the keyboard. While the typing experience is excellent, the...

    photo_2019-02-11_21-22-26.jpg Feb 11, 2019 at 4:40 AM
  2. kristalsoldier replied to the thread Just got the Surface Laptop2.

    Hi...just wanted to know what was/ is your battery life experience with the SL2? Today, was/ is my first day in the wild and 2nd day of...

    Feb 10, 2019 at 10:44 PM
  3. kristalsoldier replied to the thread Just got the Surface Laptop2.

    That is a coincidence, ain't it!! Or, maybe not so much:)

    Feb 10, 2019 at 5:35 PM
  4. kristalsoldier liked joeblow7777's post in the thread Just got the Surface Laptop2.

    Not only do you and I have the same laptop, we also have the same external hard drive, and I also watch Lisa from MobileTechReview. :D

    Feb 10, 2019 at 5:28 PM
  5. kristalsoldier replied to the thread Surface 3 Battery Burst Screen.

    Damn! Thankfully, you were ok though.

    Feb 10, 2019 at 5:26 PM
  6. kristalsoldier attached a file to the thread Just got the Surface Laptop2.

    [ATTACH] [ATTACH] [ATTACH] [ATTACH] [ATTACH] [ATTACH] [ATTACH] :D

    IMG_20190209_185333.jpg IMG_20190209_224851.jpg IMG_20190209_225921.jpg IMG_20190210_145549.jpg IMG_20190210_145602.jpg IMG_20190210_145632.jpg IMG_20190210_145651.jpg Feb 9, 2019 at 10:07 PM
  7. kristalsoldier liked joeblow7777's post in the thread Just got the Surface Laptop2.

    I just got a Black Surface Laptop 2 as well. My very first Surface product. I'm really liking it so far!

    Feb 9, 2019 at 9:55 PM
  8. kristalsoldier posted a new thread.

    Just got the Surface Laptop2

    Hi all... New device for me! Just picked up the black version of the Surface laptop 2. Change for me as I have been using the Surface...

    Forum: Surface Laptop 2

    Feb 9, 2019 at 7:15 AM
  9. kristalsoldier replied to the thread My SP6 struggles with the absolute basics....

    You could try resetting the SP6 (painful exercise, IMO, but sometimes the only option). Alternatively, you could try reinstalling the...

    Feb 8, 2019