8.1 acting strange after Windows 10 release

Discussion in 'Microsoft Surface Pro 3' started by Buck Spunni, Aug 2, 2015.

  1. Buck Spunni

    Buck Spunni New Member

    Joined:
    Feb 8, 2015
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Still running 8.1 but since the release of 10 my Surface has been acting strange... randomly getting stuck for a while when booting up, occasionally disconnecting my Bluetooth headphones, fan seems to be running more than usual. Just weird....Anyone else?
     
  2. Kris

    Kris Active Member

    Joined:
    Aug 21, 2014
    Messages:
    644
    Likes Received:
    81
    Trophy Points:
    28
    My Device:
    SPro3
    did you update to windows 10 then go back? If not I doubt it has anything to do with windows 10
     
  3. Buck Spunni

    Buck Spunni New Member

    Joined:
    Feb 8, 2015
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Haven't upgraded. Odd that it should start at the same time as the roll-out of Windows 10
     
  4. leeshor

    leeshor Well-Known Member

    Joined:
    Jun 19, 2012
    Messages:
    5,071
    Likes Received:
    877
    Trophy Points:
    113
    Location:
    Norcross, GA
    My Device:
    SPro4
    Now might be a good time to do a refresh.
     
  5. Buck Spunni

    Buck Spunni New Member

    Joined:
    Feb 8, 2015
    Messages:
    11
    Likes Received:
    0
    Trophy Points:
    1
    Just checked update history - 12 instances of failed to upgrade to Windows 10 are listed. Any idea how I can politely tell Windows to leave me alone until I'm ready, if ever?
     

Share This Page

Search tags for this page

windows surface acting weird