A few issues with surface 3

Discussion in 'Surface 3 (Atom)' started by Lalilo, May 16, 2015.

  1. Lalilo

    Lalilo New Member

    Joined:
    May 16, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    Surface 3 (Atom)
    Hello everyone, this is my first post, so let me introduce myself. I got my new surface 3 a week go, I got the 64gb version. I don't really have experience with windows at all, I've had windows before but the last version I had was the xp. windows 8 is so new to me...ive had a chance to play with it and I kinda understand it a little now, but I have a few issues with it, that to be honest it takes away from the experience. To start off I'm having issues with the windows button, when the tablet goes to sleep, and I try to wake it up by tapping on the button, nothing happens. I have to tap it a few times for it to wake up.... sometimes it vibrates and sometimes it doesn't. another issue I'm having is that web pages take so long to load, it seems worse when I hit the back button, the page takes about 15 seconds to load, I cannot scroll up or down, I've read online to try some internet settings but to be honest it did not help much... it seems worse on internet explorer than with bing. The other problem that I encountered is the loading of videos on YouTube, they look choppy, and stall while videos on my phone are playing fine. volume rocker sometimes does not work, it is so slow to put volume up or down, then at the time there was no sound, I had to restart my surface.

    I don't know if any of you have encountered any of these problems, I really wanted to love it, it seems like a great tablet, but I've ran into many problems that are too annoying, I don't know if I got a bad tablet or what, but I'm thinking of returning it...I really wanted to keep it, but 500 dollars is too much for something that is giving me trouble.
     
  2. leeshor

    leeshor Well-Known Member

    Joined:
    Jun 19, 2012
    Messages:
    5,071
    Likes Received:
    877
    Trophy Points:
    113
    Location:
    Norcross, GA
    My Device:
    SPro4
    Welcome to the forum

    If I had to make a guess, you may not have allowed it to do all the updating it needed.
     
  3. Palmkrawler

    Palmkrawler New Member

    Joined:
    May 17, 2015
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    RT
    For the Windows button issue I agree with the 2nd poster. Make sure you have installed all recommended updates and be sure it is a firm solid press in the center of the button.

    For the 2nd issue. I am assuming this is in the Metro/Modern UI Internet Explorer that you are having these issues. Very common, actually. There is a fix that can help speed up the back button issue..

    Reboot the device, then go to your DESKTOP and then launch Internet Explorer.
    Then go to Manage Addons. Go to Tracking Protection and add a provider. I just used the first one, Easylist Standard. Makes a huge difference when going back to a previous page on both the Start page version and the full IE.
     
  4. Lalilo

    Lalilo New Member

    Joined:
    May 16, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    Surface 3 (Atom)
    Thanks for your response...... my tablet is up to date. I've installed all the updates. I think its going back tomorrow, i though this tablet would be snappy... and its not, it takes several taps on the home button to wake it up.... not even the power button wakes it up.
     
  5. hughlle

    hughlle Super Moderator Staff Member

    Joined:
    Jul 7, 2014
    Messages:
    2,691
    Likes Received:
    422
    Trophy Points:
    83
    For reference I have exactly the same home button issue on my sp3. Sometimes it works, other times it requires many presses. For me its not an issue though as I just use the power button (cannot tell you the last time I used the windows button, they can remove it for all I care)

    If the power button doesn't wake it on your device either though then it sounds like something is wrong with the device. This is not normal.
     
  6. Ordnas

    Ordnas Member

    Joined:
    Oct 22, 2013
    Messages:
    61
    Likes Received:
    6
    Trophy Points:
    8
    I have this happen on sp3 too. Doesn't bother me as I just use the power button.
     
  7. LibbyLA

    LibbyLA Member

    Joined:
    May 15, 2015
    Messages:
    36
    Likes Received:
    3
    Trophy Points:
    8
    My Device:
    Other
    I always use the power button. I'll confess to not being aware that the Windows button did anything until I looked over the S3 getting started info <blush>. I probably read it when I got my SP3 and then forget.
     
  8. bmack

    bmack Member

    Joined:
    Jul 19, 2014
    Messages:
    67
    Likes Received:
    6
    Trophy Points:
    8
    Same here on my sp3. I always use my power button.
     
  9. Lalilo

    Lalilo New Member

    Joined:
    May 16, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    Surface 3 (Atom)
    Like I said I would use my power button but it doesn't respond either
    I'm thinking of replacing it...maybe I got a bad one, I don't see people online complaining of this issue on this new tablet...I do see plenty on the sp3..but not one time did I see a fix for it. In a way I want to just return it and get something different, like an iPad or samsung..but to be honest I like the whole full MS operating system in a tablet.
     
  10. LibbyLA

    LibbyLA Member

    Joined:
    May 15, 2015
    Messages:
    36
    Likes Received:
    3
    Trophy Points:
    8
    My Device:
    Other
    Lalilo,

    If you are having problems with both the Windows button and the power button, you probably did get a bad one. I'd try a replacement first before abandoning for iPad or Android.
     

Share This Page

Search tags for this page

microsoft surface 3 atom issues

,

surface 3

,

surface 3 isssues

,

surface 3 video problems

,

thinking or returning surface 3