Solved accelerometer sensor not working

Discussion in 'Microsoft Surface Pro 3' started by tjdream, Nov 1, 2015.

  1. tjdream

    tjdream New Member

    Joined:
    Dec 24, 2014
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    no help came back on with screen in landscape (Flipped ) mode and will not rotate unless I un check the auto rotate box and change it to Landscape mode in resolution settings myself
     
  2. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,968
    Likes Received:
    1,885
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    SurfaceProX
    Hmmm.... have you tried a refresh?
     
  3. tjdream

    tjdream New Member

    Joined:
    Dec 24, 2014
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Yes I tried a refresh and a restart (remove everything and reinstall windows( back to factory settings twice now
     
  4. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,968
    Likes Received:
    1,885
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    SurfaceProX
    Sounds like the Firmware update hung. You can contact MS Support and see what options are available.
     
  5. tjdream

    tjdream New Member

    Joined:
    Dec 24, 2014
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    ok thank you for your help
    Guess I'm going to try and take it by a Microsoft store next week
     
  6. tjdream

    tjdream New Member

    Joined:
    Dec 24, 2014
    Messages:
    10
    Likes Received:
    0
    Trophy Points:
    1
    Fixed Held down volume up and power for 30 seconds wait 30 seconds and push both again for 10 seconds next power off like normal then restart and all is working as it should.
     
  7. leeshor

    leeshor Well-Known Member

    Joined:
    Jun 19, 2012
    Messages:
    5,070
    Likes Received:
    877
    Trophy Points:
    113
    Location:
    Norcross, GA
    My Device:
    SPro4
    That was almost too easy. ;);)
     
  8. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,968
    Likes Received:
    1,885
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    SurfaceProX
    Excellent....that is the old key combo from the SP2....cool to see it still works on the SP3 :)
     
  9. CCB2014

    CCB2014 New Member

    Joined:
    Nov 4, 2015
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro3
    I just repaved my SP3, and still have the same issues as OP -- screen is flipped, keyboard is not recognized.
    I thought it was somehow due to having attached an SP4 dock, but may that wasn't the issue.
    Right now, my expensive tablet/laptop is a brick...

    Update:
    After shutting down and restarting, the screen is right-side up, but the keyboard still doesn't work.
     
    Last edited: Nov 4, 2015
  10. Rob Ruston

    Rob Ruston New Member

    Joined:
    Dec 3, 2019
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro3
    Old thread now I know but I've just been having accelerometer issues on an SP3 (i5 / 256gb model) after updating to version 1909 (Nov 19) and this process fixed it for me so thanks!!!
     

Share This Page

Search tags for this page
microsoft accelerometer problem
,
ms surface accelerometwr stopped working
,
surface book accelerometer
,
surface pro 3 accelerometer not working
,
surface pro 3 sensors not working
,

surface pro 4 accelerometer not working

,
surface pro accelerometer not working
,

surface pro4 auto rotation is not working

,
surface sensor problem
,
the acceleration sensor driver is not installed