Anyone else notice unstable connection to USB devices?

Discussion in 'Microsoft Surface Pro 4' started by Darnellmc, Aug 10, 2016.

  1. Darnellmc

    Darnellmc New Member

    Joined:
    Nov 28, 2015
    Messages:
    28
    Likes Received:
    2
    Trophy Points:
    3
    My Device:
    SPro4
    I've had my SP4 since shortly after initial product launch. And since day 1, devices connected either via the SP4 USB port or even the dock USB ports, have always been unstable. The connection works and then disconnects and comes back again, back and forth. But pretty much to a point of the USB devices being useless with the SP4.

    I've got other machines, so this has never been a major issue for me. I just use my other machines for things like CD/DVD and other USB device needs.

    But has anyone else noticed USB device connection stability issues with their SP4? It really surprises me, that the issues are with both the SP4 USB port and even the dock's USB ports. My mouse and keyboard work fine with the dock's USB ports. But everything else, such as CD/DVD player, card readers and portable storage devices, all have issues with all USB connections to my SP4, either via the device its self or the docking station. And since those same USB devices work fine with my other machines, I know they're not faulty.
     
  2. Votality

    Votality Member

    Joined:
    Nov 25, 2015
    Messages:
    72
    Likes Received:
    4
    Trophy Points:
    8
    My Device:
    SPro4
    No problems here
     
  3. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,095
    Likes Received:
    1,724
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    When I have seen this it is typically caused by the USB device drawing more power than the port can support, using a powered Hub usually fixes it....
     
  4. Votality

    Votality Member

    Joined:
    Nov 25, 2015
    Messages:
    72
    Likes Received:
    4
    Trophy Points:
    8
    My Device:
    SPro4
    I thought that but doesn't the dock have powered ports?
     
  5. Darnellmc

    Darnellmc New Member

    Joined:
    Nov 28, 2015
    Messages:
    28
    Likes Received:
    2
    Trophy Points:
    3
    My Device:
    SPro4
    Here's one device I've had consistent issues with, whether connected via dock or directly to the SP4 USB port:
    Bengoo USB 3.0 External DVD Drive

    The DVD Drive works with no issues, when connected to my Windows 10 Desktop machine. (And this is the 2nd portable DVD Drive I've tried.)

    I do have the SP4 connected to power, when I attempt to use the SP4 USB port. I did assume the dock has powered ports. I do have the dock connected to power.

    The dock ports are able to power my Android phone with no issues regarding charging the phone. But if I put the phone into Fastboot USB, the SP4 is unable to connect to it using Fastboot commands. That's not something I was going to bother folks here about though, since that gets into issues involving Android device access. But for anyone familiar, I can connect the phone via USB as a storage drive just fine, but soon as I try to go into Fastboot USB, the phone recognizes Fastboot USB, but no fastboot commands from the SP4 work. No issues when doing the same with my Windows 10 Desktop machine.
     
  6. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,095
    Likes Received:
    1,724
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    It still has limits on the amperage it can supply....
     
  7. Darnellmc

    Darnellmc New Member

    Joined:
    Nov 28, 2015
    Messages:
    28
    Likes Received:
    2
    Trophy Points:
    3
    My Device:
    SPro4
    Thank you, I will have to try a powered USB hub.
     
  8. kristalsoldier

    kristalsoldier Well-Known Member

    Joined:
    Feb 24, 2013
    Messages:
    2,314
    Likes Received:
    357
    Trophy Points:
    83
    My Device:
    SPro4
    No problems here either. I have two external drives attached with no issues (as of now).
    Edit: One of the external drives is an externally powered one though. The other one is a portable HDD (WD Passport).
     
  9. Darnellmc

    Darnellmc New Member

    Joined:
    Nov 28, 2015
    Messages:
    28
    Likes Received:
    2
    Trophy Points:
    3
    My Device:
    SPro4
    I found one of my old USB Hubs, but it was not working, broken USB Hub. Since I had not tried since the "Anniversary Update", I tried without the SP4 Hub and my portable CD/DVD player worked fine when plugged directly into the SP4. Then I tried with the SP4 Hub and still have connection issues with it. So at least it works directly with the SP4.

    I'll have to try with the SP4 Hub when I have a working powered USB Hub.
     
  10. Darnellmc

    Darnellmc New Member

    Joined:
    Nov 28, 2015
    Messages:
    28
    Likes Received:
    2
    Trophy Points:
    3
    My Device:
    SPro4
    I got a good powered USB Hub and the USB CD/DVD player/burner is working stable, when connected directly to the Surface Pro 4. But when I use the Surface Hub, it does not work. When connected to the Surface Hub, the powered USB Hub lights up and when connection the CD player, the CD Player lights up and opens, but Windows never sees it, even with a CD installed.
     
  11. kristalsoldier

    kristalsoldier Well-Known Member

    Joined:
    Feb 24, 2013
    Messages:
    2,314
    Likes Received:
    357
    Trophy Points:
    83
    My Device:
    SPro4
    I have noticed this too - mostly before this most recent update (.321 on RP). My SP4 is connected to the dock. Two external HDDs connect to the dock. Often times, the two drives dont show up. But if I wiggle the power chord to the SP4 the drives show up. But after this most recent update, this seems to have worked itself out and the drives show up ok with a little bit (maybe 30 sec) delay.
     
  12. MikemanSP4

    MikemanSP4 Active Member

    Joined:
    Dec 15, 2015
    Messages:
    147
    Likes Received:
    27
    Trophy Points:
    28
    My Device:
    SPro4

    Not a single issue with my USB Port at all......... One thing you might want to do is........ Download the latest Surface Pro 4 Drivers and un / re-install them. This has taken care of SO MANY issues over the past year it's pathetic. Sometimes updates, or even a faulty USB Device can corrupt the USB (or any device) Drivers. A uninstall / re-install will clear these issues right up. Here is the link for the latest and greatest SP4 Drivers - Please let me know if this helped you at all.

    Download Surface Pro 4 Drivers and Firmware from Official Microsoft Download Center
     
    kristalsoldier likes this.

Share This Page