Auto brightness disabled, yet still there. How to get rid of it?

Discussion in 'Microsoft Surface Pro 3' started by baandoptager, Jan 10, 2015.

  1. baandoptager

    baandoptager New Member

    Joined:
    Nov 3, 2013
    Messages:
    23
    Likes Received:
    1
    Trophy Points:
    3
    There were many reasons why i ditched the Surface Pro (After 6 of them), was among other things the incredible annoying "auto brightness" bug.

    It is on my Surface Pro 3 too. And... no matter what i do, it won't go away.

    Can anyone help?

    PS: It's not really auto brightness, but a gentle dimming of the display once in a while. It is totally uncool on a screen that is supposed to help me get colors right for clients and so forth. Its driving me nuts!
     
  2. hughlle

    hughlle Super Moderator Staff Member

    Joined:
    Jul 7, 2014
    Messages:
    2,957
    Likes Received:
    456
    Trophy Points:
    83
    My Device:
    SPro4
    The only dimming of the screen i have encountered (i never use auto brightness, just set it as i like it) is just before it goes into sleep, like with all mobile products.
     
  3. PCAnyWhere

    PCAnyWhere Member

    Joined:
    Dec 23, 2014
    Messages:
    60
    Likes Received:
    11
    Trophy Points:
    8
    Location:
    Toronto, Canada
    My Device:
    SPro3
    In the power options there are two settings. One for auto-dimming and another for Adaptive Brightness. you can adjust both. is this what you are referring to?
     
    ptrkhh and GreyFox7 like this.
  4. ptrkhh

    ptrkhh Active Member

    Joined:
    Nov 15, 2014
    Messages:
    394
    Likes Received:
    77
    Trophy Points:
    28
    My SP3 even shipped with the auto-brightness off. It seems like they know that they kinda messed up in that area.
     
  5. GreyFox7

    GreyFox7 Super Moderator Staff Member

    Joined:
    Jul 27, 2014
    Messages:
    6,570
    Likes Received:
    1,314
    Trophy Points:
    113
    I have auto brightness disabled on every device I have. ever watch a street light come on and off and dusk or dawn?... same thing. Ambient light fluctuations at the cutoff point are unavoidable ... see clouds on a sunny day.
     
  6. baandoptager

    baandoptager New Member

    Joined:
    Nov 3, 2013
    Messages:
    23
    Likes Received:
    1
    Trophy Points:
    3
    Turned dimming to 0% and auto brightness off. Its still there..... whenever i switch between a light and dark page, it slowly goes : 1 step, 2 step, 3 step. What is it about? Im starting to get annoyed with me surface pro 3, soooo many things to tweak just to get normal behaviour. I dont want others (vendors) to decide what i do with my machine. i want control. I payed good money for it!
     
  7. GreyFox7

    GreyFox7 Super Moderator Staff Member

    Joined:
    Jul 27, 2014
    Messages:
    6,570
    Likes Received:
    1,314
    Trophy Points:
    113
    Sounds like its not a good match for you, return it.
     
  8. ptrkhh

    ptrkhh Active Member

    Joined:
    Nov 15, 2014
    Messages:
    394
    Likes Received:
    77
    Trophy Points:
    28
    Ah I get it, its Intel's GPU power saving feature.

    You can turn it off with the Surface Tweak Tool (The option is "Dynamically adjust the contrast ratio when on battery.").
    Another way to do that is to use Intel's GPU driver to gain the full GPU Control Panel. Just download it off downloadcenter.intel.com, then install the driver (try using Have Disk method)

    I also disabled that option on all my devices.
     
  9. baandoptager

    baandoptager New Member

    Joined:
    Nov 3, 2013
    Messages:
    23
    Likes Received:
    1
    Trophy Points:
    3
    Doesn't work either. But, you're right, it only happens in batter mode.
     
  10. ptrkhh

    ptrkhh Active Member

    Joined:
    Nov 15, 2014
    Messages:
    394
    Likes Received:
    77
    Trophy Points:
    28
    Have you tried installing Intel GPU driver?

    Open downloadcenter.intel.com, then pick "Graphics Driver", pick "Laptop graphics driver", and pick the appropriate GPU for your SP3 (i3: 4200, i5: 4400, i7: 5000). After the installation has finished, extract the archive.

    Now open Device Manager, expand the "Display adapters" tree, and right click on the GPU driver (On my i3, its Intel(R) HD Graphics Family), and click "Update Driver Software"
    Click "Browse my computer for driver software", then click "Let me pick from a list of device drivers on my computer", and click "Have Disk..."

    Click "Browse", then open the extracted archive, and open the "Graphics" folder. There should be one .inf file, click it and proceed.

    After the installation has finished, the Intel HD Graphics Control Panel should appear when you right click on the desktop.

    You can disable the dynamic contrast adjustment there.
     
    Haldi likes this.
  11. r0b123

    r0b123 Active Member

    Joined:
    Jul 30, 2014
    Messages:
    217
    Likes Received:
    34
    Trophy Points:
    28
    Location:
    Issaquah, WA (USA)
    My Device:
    SPro3
    Hmm, maybe it's resolved in Win 10 TP? Setting is off on mine and from what I can tell, it does happen in battery mode once I disconnect power, but I use turn the brightness up 2 or 3 levels to maintain the level before.

    upload_2015-1-11_8-10-3.png
     
  12. baandoptager

    baandoptager New Member

    Joined:
    Nov 3, 2013
    Messages:
    23
    Likes Received:
    1
    Trophy Points:
    3

    This is what the tweak tool does, if im not mistaking. Doesn't work!
     

Share This Page

Search tags for this page

brightness wont go down surface pro 3

,

disable dynamic contrast ratio surface book

,

get rid of adaptive brightness

,

how to disable auto brightness on your laptop win10

,

how to get rid of auto brighntess

,

how to get rid of brightness bar on surface

,

microsoft surface 4 auto dim off

,

sp3 brightness auto

,

surface book adaptive brightness

,

surface pro 3 adaptive brightness wont stay of