battery indicator stalled while charging

Discussion in 'Microsoft Surface Pro 4' started by psv, Sep 2, 2016.

  1. psv

    psv New Member

    Joined:
    Apr 19, 2016
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro4
    I have a strange problem which appeared, I think, after the Anniversary update: when charging, the battery indicator shows the same number, say 35%, for a long time. If I unplug, it jumps to the correct value, say 57%, but if I don't, it just stays constant (well, mostly - sometimes it jumps also when charging, but by large numbers). Is it working normally for you? Microsoft support suggested that they would replace my SP4 if the problem persists after factory reset (it does), but I'd like to check with others before doing so.
     
    Last edited: Sep 2, 2016
  2. SNLJ

    SNLJ New Member

    Joined:
    Aug 11, 2016
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro4
    I had this happen for the first time today. Not a huge issue for me. I certainly have bigger ones with this computer.
     
  3. psv

    psv New Member

    Joined:
    Apr 19, 2016
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro4
    I wouldn't really care, but I worry about consequences for the battery if the system gets wrong values (I've had this issue for a month and it's not going away). Also, as nobody else (well, besides you now) reported this problem, it may be something hardware-related.
     
  4. rcwilkinson

    rcwilkinson New Member

    Joined:
    Sep 16, 2016
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro4
    I have this issue also!

    Are you going to ask for a replacement from MS? I was wondering if I ought to as well. I've also experience some other interesting battery issues.....

    Ross

    p.s. is happens whether plugged in via the standard charger, or MS dock
     
    Last edited: Sep 16, 2016
  5. psv

    psv New Member

    Joined:
    Apr 19, 2016
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro4

    Did it start with the Anniversary Update? I'm not yet sure about asking for replacement (it was what online Microsoft support suggested, but perhaps it is a software issue, thought only few people seem to have it).
     
  6. rcwilkinson

    rcwilkinson New Member

    Joined:
    Sep 16, 2016
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro4
    To be honest....I dont know

    I only started observing yesterday. I am monitoring my battery closely now, as it managed to crash from 65% in power to 0%, in a matter of 10mins. (see other thread). So, naturally I'm a bit concerned that it's a hardware prob

    Ross
     
  7. polbit

    polbit Member

    Joined:
    Dec 14, 2012
    Messages:
    112
    Likes Received:
    14
    Trophy Points:
    18
    My Device:
    Other
    Mine's doing the same thing suddenly. Doesn't really effect anything, just have to unplug/plug it back in, but annoying. I would certainly not return the unit just for that, if everything else is working...
     
  8. psv

    psv New Member

    Joined:
    Apr 19, 2016
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro4
    Besides unplug/plug you can also try checking for updates in the Settings - in my case it updates the battery level to the right value (why? it's totally beyond me). Also checking for update of any driver in the Device Manager does the same thing.
     
  9. kristalsoldier

    kristalsoldier Well-Known Member

    Joined:
    Feb 24, 2013
    Messages:
    2,314
    Likes Received:
    358
    Trophy Points:
    83
    My Device:
    SPro4
    In my experience, yes. I have noticed this post the AU. Its sometimes a bit disconcerting! I have observed this behaviour for some time though, which means I have consistently checked if the unit is charging. Now that I am a bit more confident that it charges all right, I pretty much ignore it. But yes, I do notice this issue post the AU.
     
  10. rcwilkinson

    rcwilkinson New Member

    Joined:
    Sep 16, 2016
    Messages:
    18
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro4
    Hi guys, for those with this issue - do your battery ever get to 100%, even when you do the 'unplug/plug' trick, or 'updates check' trick?

    Mine stops at 99% and never improves on '05mins to full charge'....
     
    Last edited: Sep 19, 2016
  11. muhdhadi91

    muhdhadi91 New Member

    Joined:
    Oct 7, 2016
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro4
    Hey guys. I have the exact problem too after the anniversary update!! What should I do? Just bought my surface pro 4 1 month ago
     
  12. bluegrass

    bluegrass Well-Known Member

    Joined:
    Nov 11, 2013
    Messages:
    1,301
    Likes Received:
    193
    Trophy Points:
    63
    Location:
    St. Louis, Mo
    My Device:
    SPro3
    No big deal. I never check the indicator while it's charging. I only look at the battery level indicator once in a while if I'm out boon docking and been off the grid for awhile. I certainly wouldn't trade my Surface for an unknown if that is the only problem you're having. I would only become concerned if when you're fully charged, the battery doesn't allow you to use your Surface for an acceptable amount of time.

    Always backup important data once in awhile to give you a hedge for a bad disaster. Don't worry about the small stuff. You can always reinstall your software.
     

Share This Page