Cannot zoom in or out using Chrome browser.

Discussion in 'Microsoft Surface Pro 2' started by Darren Donovan, Jan 16, 2014.

  1. Darren Donovan

    Darren Donovan Member

    Joined:
    Oct 25, 2013
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    Microsoft must have put in some roadblocks to harass Chrome users. I test out the same webpages on IE and Chrome. Zoom works fine on IE, but totally nonresponsive in Chrome. I have no affinity for Chrome, just have been using it for a while, just a familiarity thing. I heard that IE is (or used to be) not as efficient as other browsers, not sure if that is true.
     
  2. jollywombat

    jollywombat Member

    Joined:
    Nov 25, 2013
    Messages:
    171
    Likes Received:
    22
    Trophy Points:
    18
    Location:
    NY, USA
    My Device:
    SPro2
    This has nothing to do with Microsoft, it is google that has to implement the functionality into chrome. Pinch to zoom and any other touch gestures are not just a system implemented function applied to all applications.
     
  3. MickeyLittle

    MickeyLittle Active Member

    Joined:
    Jun 18, 2012
    Messages:
    454
    Likes Received:
    51
    Trophy Points:
    28
    Location:
    Mississippi
    My Device:
    SPro3
    Here is another current thread going about Chrome and different settings that you can change to help with it but for me so far it is IE all the way!

    http://www.surfaceforums.net/forum/microsoft-surface-pro-2/7698-chrome-windows-8-mode.html
     
  4. Darren Donovan

    Darren Donovan Member

    Joined:
    Oct 25, 2013
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    Thanks for that link. I'll just learn to use IE. I like trying out new stuff. Chrome's pinch to zoom function worked very well when I still had the Google Nexus 10.
     
  5. MickeyLittle

    MickeyLittle Active Member

    Joined:
    Jun 18, 2012
    Messages:
    454
    Likes Received:
    51
    Trophy Points:
    28
    Location:
    Mississippi
    My Device:
    SPro3
    Of course it did, hence the Google Nexus and the Google Chrome! :cool2:
     
  6. iliketoys

    iliketoys New Member

    Joined:
    Dec 22, 2013
    Messages:
    23
    Likes Received:
    3
    Trophy Points:
    3
    I've been using Google Canary (Chrome Beta) since the Surface launch. Pinch and Zoom and other touch screen gestures work. Plus you get your synched tabs...
     
  7. daniielrp

    daniielrp Active Member

    Joined:
    Oct 26, 2013
    Messages:
    693
    Likes Received:
    133
    Trophy Points:
    43
    Location:
    Preston, UK
    My Device:
    SPro3
    Synched tabs work with any version of Chrome.
     
  8. xGary

    xGary New Member

    Joined:
    Nov 25, 2013
    Messages:
    12
    Likes Received:
    6
    Trophy Points:
    3
    Go to Chrome://Flags and enable "Pinch Scale".

    Other things to enable:
    -"Enable touch events"
    -"Touch Optimized UI"

    To fix the DPI issue, either enable "HiDPI Support" in flags or right click on Chrome Icon > Properties > Compatibility > Check "Disable displaying scaling for high DPI". Those two options provide different results so you might want to see which one you like.
     
  9. beq

    beq Member

    Joined:
    Nov 9, 2013
    Messages:
    196
    Likes Received:
    14
    Trophy Points:
    18
    Location:
    USA
    Thanks for the info!

    Interestingly I seemed to get the best HiDPI result by doing both (enabling "HiDPI Support" flag and checking Compatibility "Disable display scaling for high DPI"). In fact, enabling only the HiDPI flag in the latest Chrome v32/v33 seems to break things in terms of touch input mapping, whereas checking only the Compatibility setting leaves everything too small at the default 100% zoom... Curious how these 2 HiDPI options differ, and how they interact...

    Anyways, I do appreciate the experimental touch optimized UI with bigger spacing, as well as enabling pinch to zoom. But what does the "Enable touch events" change as far as running Chrome on the SP2, if I may ask?
     
    Last edited: Jan 21, 2014

Share This Page

Search tags for this page
cannot zoom in with chrome
,

chrome pinch to zoom surface pro 4

,
chrome zoom settings
,
get out of zoom mode in chrome google nexus tabkt
,
google chrome pinch to zoom on surface pro 3
,
google chrome zoom surface
,
how to zoom in on surface pro without pinch
,
how to zoom in with google chrome on iphone
,
how to zoom out of a page surface pro google chrome
,
zoom chrome surface pro