Can't Detach with OneDrive for Business Running

Discussion in 'Microsoft Surface Book' started by BigZAJ, Jun 20, 2016.

  1. BigZAJ

    BigZAJ New Member

    Joined:
    Nov 9, 2015
    Messages:
    24
    Likes Received:
    2
    Trophy Points:
    3
    My Device:
    Surface Book
    My company just rolled out OneDrive for Business and I am in the beta testing group. I've found that I cannot detach my screen when running OneDrive for Business. I get a message to "Please resolve before detaching" that shows "GROOVE" (I think the sync app?) in all caps with the OneDrive cloud. When I close OneDrive for business I am able to detach immediately.

    OneDrive personal does not have this limitation. Any thoughts on how to resolve this besides shutting down OneDrive frequently?
     
  2. JaeMelo

    JaeMelo Member

    Joined:
    Mar 14, 2016
    Messages:
    42
    Likes Received:
    2
    Trophy Points:
    8
    My Device:
    Surface Book
    Not sure if this'll work but its worth a try... Go into the NVidia Control Panel and force all the related apps to your detaching issue like (OneDrive Business, Groove, ect) to use the internal GPU only. Restart and give the detaching thing another go.
     
  3. BigZAJ

    BigZAJ New Member

    Joined:
    Nov 9, 2015
    Messages:
    24
    Likes Received:
    2
    Trophy Points:
    3
    My Device:
    Surface Book
    This appears to have worked, but now I'm getting hit with "SearchProtocolHost" needing to be resolved.
     
  4. JaeMelo

    JaeMelo Member

    Joined:
    Mar 14, 2016
    Messages:
    42
    Likes Received:
    2
    Trophy Points:
    8
    My Device:
    Surface Book
    Not sure if that OneDrive Business beta program is the culprit but you could try restarting the service related to "SearchProtocolHost".

    Go to Run or press Win + R and type is the text field services.msc
    Scroll to the bottom till you see Windows Search and right click the service and hit restart.
    If that doesn't resolve your issue you may have to simply undo forcing internal GPU stuff you did earlier until Microsoft creases out the bug/s that're causing all of this.
     

Share This Page

Search tags for this page

please resolve before detaching