Solved Can't find option for Hello Login

Discussion in 'Microsoft Surface Pro 4' started by wanderzushi, Nov 27, 2015.

  1. wanderzushi

    wanderzushi New Member

    Joined:
    Nov 27, 2015
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro4
    So, among the many issues with the SP4 (I seem to have nearly all of them but the boot loop), I can't activate the windows Hello login.

    I know where it should be in the sign in options, but it just isn't there.

    I can see Password, PIN (which I have assigned and am using to log-in), and Picture Password. I don't see any options for the Hello. When I search in Cortana for Hello it takes me to the same page in settings.

    Any body else having this problem or know how to solve it?

    example.png
     
  2. sharpuser

    sharpuser Super Moderator Staff Member

    Joined:
    Aug 20, 2013
    Messages:
    2,854
    Likes Received:
    1,030
    Trophy Points:
    113
    Location:
    Pacific Northwest & China
    My Device:
    Surface Book
    Hi, @wanderzushi

    Your infrared camera is not being detected. You should "Reset" Windows 10 on your SP4.

    Let us know how it goes.
     
  3. GatsbyGlen

    GatsbyGlen Member

    Joined:
    Nov 6, 2015
    Messages:
    85
    Likes Received:
    9
    Trophy Points:
    8
    My Device:
    SPro4
    Try looking in Device Manager, and under System Devices, make sure Surface Camera Windows Hello is listed. You can also try booting into the UEFI menu and make sure it wasn't disabled there. To get to the UEFI menu

    Shutdown
    Hold Volume UP down (not Volume Down)
    Press and Release Power Button (keep Volume UP held down)
    UEFI screen will display
    Goto Devices - Here you can toggle on and off the following
    • Docking USB
    • Front Camera
    • Rear Camera
    • IR Camera
    • Wi-Fi & Bluetooth
    • Bluetooth
     
  4. wanderzushi

    wanderzushi New Member

    Joined:
    Nov 27, 2015
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro4
    Thanks GatsbyGlen, unfortunately I checked both the UEFI menu as well as in the device manager and it seems to be enabled in both places. I'd rather not have to go through a reset if possible but I guess I can. How do you do that? Any other suggestions?

    I should have said I've applied all the updates.
     
  5. GatsbyGlen

    GatsbyGlen Member

    Joined:
    Nov 6, 2015
    Messages:
    85
    Likes Received:
    9
    Trophy Points:
    8
    My Device:
    SPro4
    What version of the driver is installed for the Camera? The following might help.

    Why is the Windows Hello option missing on a Surface Pro 4 or Surface Book ? | just another windows noob ?
     
    wanderzushi likes this.
  6. wanderzushi

    wanderzushi New Member

    Joined:
    Nov 27, 2015
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro4
    Wow, thanks for that again GatsbyGlen, i've had a hard time searching for his problem.

    I had tried specifically updating the driver for the Hello camera by requesting an update "automatically" from device drivers it didn't come up with anything. Checking the version the IR camera is definitely using the out of date version from August, and not the October version mentioned in the article.

    It seems I'm now downloading the Nov 18 firmware, and after that applies I'll see where we are and then apply the manual driver update recommended in that article. Will reply back once its all wrapped up. (slow internet connection here)
     
  7. GatsbyGlen

    GatsbyGlen Member

    Joined:
    Nov 6, 2015
    Messages:
    85
    Likes Received:
    9
    Trophy Points:
    8
    My Device:
    SPro4
    Hopefully that works. There are two things that can actually be downloaded. The recovery image, if you wish to start from the beginning and refresh from a USB stick. Or, you can download the driver/firmware package (as a zip) and then install the driver manually for the IR camera.

    Link to Recovery Image (good to have handy just in case)
    Download a recovery image for Microsoft Surface

    Link to latest driver/firmware package
    Download Surface Pro 4 Drivers and Firmware from Official Microsoft Download Center
     
    wanderzushi likes this.
  8. wanderzushi

    wanderzushi New Member

    Joined:
    Nov 27, 2015
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro4
    Ugh, the download of the firmware update seems to be stuck at 15% and isn't moving. Any tips there or should I just give up and reset?
     
  9. leeshor

    leeshor Well-Known Member

    Joined:
    Jun 19, 2012
    Messages:
    5,071
    Likes Received:
    877
    Trophy Points:
    113
    Location:
    Norcross, GA
    My Device:
    SPro4
    Is it the download or the install that's stuck? If it's the install make sure you don't have an SD card inserted.
     
  10. GatsbyGlen

    GatsbyGlen Member

    Joined:
    Nov 6, 2015
    Messages:
    85
    Likes Received:
    9
    Trophy Points:
    8
    My Device:
    SPro4
    I backed up the driver - you can grab it here, it's 190KB :)

    Surface Camera Windows Hello.zip

    You'll need to install manually through the device manager.
     
  11. wanderzushi

    wanderzushi New Member

    Joined:
    Nov 27, 2015
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro4
    Downloading driver for security application via random person on the internet... dodgy, but effective, and I supposed they're signed. It worked. I was able to enable the Hello service and it works very well. Thanks. If

    It seemed my main problem was having the Nov 18, 2015 firmware stuck and not downloading:

    Once it got downloading again (after several restarts, multiple retries, and a failed attempt at resetting the windows update utility from Microsoft, it finally got going again (randomly). So I rolled back your driver and let the update proceed. It completed successfully, reboot, and didn't work. Checked updates again: same Nov 18, 2015 firmware update showing, downloaded and installed Again, and now Hello camera works. The version has been updated to the new version from the article you posted 10.0.24.0. Yay! Great success.

    It also seems like my weird color tone flicker bug (changes from green to red hue for the whole screen while scrolling in edge) has been fixed as well, but I'm not convinced yet. Any thoughts on that one?

    Also my display driver has started crashing. Nothing but problems so far with this thing. Onto a new thread. And thanks again.
     
  12. GatsbyGlen

    GatsbyGlen Member

    Joined:
    Nov 6, 2015
    Messages:
    85
    Likes Received:
    9
    Trophy Points:
    8
    My Device:
    SPro4
    Tint changing was supposed to be fixed with one of the updates. I saw that when I first got the device, but haven't seen it since applying the first firmware update.

    Display driver crashing - that's happening to everyone. I don't see it any longer since I don't use Edge. Some of have had success with using the beta driver from Intel. I think it will eventually be resolved.
     

Share This Page

Search tags for this page

cant see hello login option

,

cant see windows hello option in surface 4

,

windows hello no option

,

windows hello options not available with surface book