Chrome and Windows 8 Mode

Discussion in 'Microsoft Surface Pro 2' started by thimetolive, Jan 14, 2014.

  1. thimetolive

    thimetolive New Member

    Joined:
    Dec 16, 2013
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    0
    Has anyone tried the latest stable release of Chrome? After downloading it on my Surface Pro 2, I no longer have the "Relaunch Chrome in Windows 8 mode" option. I checked and Chrome is still my default browser. I even uninstalled and reinstalled. It seems like it could be specific to the Surface Pro because it is working fine on my desktop. Anyone else seen this issue?
     
  2. thimetolive

    thimetolive New Member

    Joined:
    Dec 16, 2013
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    0
    Looks like it may be an issue with how Windows handles DPI scaling. I turned down to 1600x900 and it works perfectly. Anyone able to get it working at full resolution?

    On a side note: I'm digging the new "metro" interface for chrome. It's like turning your surface into a chromebook.
     
  3. tinycg

    tinycg Member

    Joined:
    Jan 8, 2014
    Messages:
    37
    Likes Received:
    2
    Trophy Points:
    8
    Location:
    Northeast
    Hmm. I knew it had an issue with the touch points being offset so I haven't tried it since. I'll see if I can reproduce the issue with the latest version.
     
  4. EthanDavis

    EthanDavis Member

    Joined:
    Jan 4, 2014
    Messages:
    73
    Likes Received:
    3
    Trophy Points:
    8
    Chrome has always looked beautiful in Windows 8 mode. It's in Desktop mode that it looks blurry. There is an easy fix for this though -- right click the desktop icon, choose compatibility, and then check "disable display scaling". Fixes the blurriness issue.

    Also, just updated Chrome to the newest release and still have the "switch to Windows 8 mode" option, even though I'm not using it.
     
    Last edited: Jan 14, 2014
  5. bertopl

    bertopl Active Member

    Joined:
    Feb 10, 2013
    Messages:
    176
    Likes Received:
    29
    Trophy Points:
    28
    Location:
    Las Vegas, NV
    latest chrome update is unusable on my SP1. when I launch chrome, it looks corrupted on the screen occupying a small portion of the upper left corner of the screen. chrome used to occasionally launch corrupted like this previously, I used to have to swipe the screen to get to settings and it would restore the window to normal. the latest update no longer has a settings item in the menu when I swipe so I can't get chrome to display properly. I tried changing resolutions like thimetolive suggested but it would only work when I set the resolution very low. gonna try to uninstall / reinstall to see if it fixes anything up.
     
    Last edited: Jan 14, 2014
  6. kayzee

    kayzee Well-Known Member

    Joined:
    May 31, 2013
    Messages:
    2,082
    Likes Received:
    228
    Trophy Points:
    63
    Location:
    Essex, UK
    My Device:
    SPro
    Was reading about the big update this morning and was looking forward to getting home and trying it.. after reading this thread though, not so much!
     
  7. bertopl

    bertopl Active Member

    Joined:
    Feb 10, 2013
    Messages:
    176
    Likes Received:
    29
    Trophy Points:
    28
    Location:
    Las Vegas, NV
    well, I ended up uninstalling and reinstalling chrome. works now but only in desktop mode on my machine. no "relaunch in windows 8 mode" option in my menu anymore.
     
  8. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,095
    Likes Received:
    1,724
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
  9. CreativeLemming

    CreativeLemming Active Member

    Joined:
    Dec 11, 2013
    Messages:
    147
    Likes Received:
    25
    Trophy Points:
    28
    Location:
    London
    According to Google, this is a known issue:

    "Windows 8 mode doesn't work on hi DPI devices. If you are on a high-resolution display, Windows 8 mode isn't accessible."
     
    Last edited: Jan 15, 2014
  10. bertopl

    bertopl Active Member

    Joined:
    Feb 10, 2013
    Messages:
    176
    Likes Received:
    29
    Trophy Points:
    28
    Location:
    Las Vegas, NV
    thanks!! seems backwards but I can dig it. I'm not in love with chrome but like how all my bookmarks, extensions, settings etc sync. I may give IE another go.
     
  11. kayzee

    kayzee Well-Known Member

    Joined:
    May 31, 2013
    Messages:
    2,082
    Likes Received:
    228
    Trophy Points:
    63
    Location:
    Essex, UK
    My Device:
    SPro
    Yes I read this, interesting. I'm not particularly bothered... does Chrome work properly in Modern UI mode yet? When I first tried it wasn't able to pinch to zoom etc. tbh I love Chrome and use it everywhere, but thus far I'm forced to keep IE as my default browser in order to use the Modern UI version of it.
     
  12. Arizona Willie

    Arizona Willie Active Member

    Joined:
    Feb 24, 2013
    Messages:
    685
    Likes Received:
    51
    Trophy Points:
    28
    Location:
    Mesa, Arizona
    I got to fooling around trying to make Chrome work in a new mode.
    Had to make Chrome the default browser to get it to work in Windows 8 mode.

    AND IT SUCKS BIG TIME.

    I quickly went into Internet Exploder and set it back as the default in order to get rid of Chrome in Windows 8 mode.
    ABSOLUTELY TERRIBLE.
    Someone at Chrome should get FIRED.
     

Share This Page

Search tags for this page

chrome for surface

,
chrome for surface pro
,

chrome for windows 8 surface

,
chrome windows 8 mode surface
,

chrome windows 8 mode surface pro

,
chrome windows 8 mode surface pro 3
,
google chrome for surface
,
google chrome for surface pro 2
,
google chrome surface pro 2
,
surface chrome