Computer's Not Talking to Each Other

Discussion in 'Microsoft Surface Help' started by Richard Jones, Apr 17, 2013.

  1. Richard Jones

    Richard Jones Member

    Joined:
    Apr 11, 2013
    Messages:
    30
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    Woking, Surrey, England
    My Device:
    RT
    In my recent thread “How Computers Talk to Each Other” I received a huge amount of valuable and generous information from Kristalsoldier and Russ about Homegroups, Setting up a Network and Remote Desktop Access for which I was really very grateful. Russ asked me to let him know how I got on: because of my lack of success I have started a separate thread for my report!

    I am using Windows 7 Home Premium 64-bit on my PC (which is protected by Norton Internet Security 2011 as updated) with Windows Live Mail whilst my Surface is the standard RT model. My router shows as an Internet Gateway Device and Netgear VMGD485 from Virgin Media.

    Having spent ten or more hours playing with the various switches and buttons and borrowed several books about Windows 8 from the library (including the huge tome “Windows 8 The Missing Manual” by David Pogue) I have achieved only the following.

    From the Surface I can open the Homegroup and can access documents etc on my PC but only in Read-Only mode which makes making any amendment difficult and tiresome. The PC recognises the existence of the Homegroup but, when I try to open it, it throws up a message saying that no other Homegroup Devices or Printers are available. I have followed the Troubleshooting procedures but I’m afraid these have led nowhere. So what I have is a one way Homegroup with only limited use.

    Clicking on the Network item in the left pane of the Explorer Window on both machines identifies both the Surface and the PC. Tapping the PC connection on the Surface reveals the files on the PC which I can then access but again on a Read-Only basis only. Clicking on the Surface connection in the PC ‘s Window results in a message saying that the Surface cannot be accessed. Again the Troubleshooting links have led nowhere.

    It follows from all of this that Remote Access Desktop will not work either.

    Opening the Change Adapter Settings in the Network and Sharing Centre and then opening the Local Area Sharing Properties Window shows two tabs on the PC (Network and Sharing) but the Sharing Tab is missing on the Surface window although I have been able to turn sharing on here by right clicking the Wi-Fi button in the Settings sequence.

    Having only these one-way and limited connections is so frustrating as is my inability to Remote Access from one to the other!

    Any help will be very much appreciated.

    Richard
     
  2. Russ

    Russ Active Member

    Joined:
    Nov 19, 2012
    Messages:
    600
    Likes Received:
    113
    Trophy Points:
    43
    Location:
    North Georgia, USA
    Hello, Richard --

    I have numbered the items in the quote above for ease of reference.

    1 - "only in Read-Only mode" -- Not sure what you mean here, but we need to sort out some other stuff first.

    2 - I think this is a Sharing issue. On the RT, use File Explorer, expand Computer so it shows Drive C -- Windows (C) -- Right Click on C and choose Properties. In the Properties dialog box, open the Sharing tab. I suspect that this drive is not shared. Click on Advanced Sharing. At the top of that box is an item called "Share this folder." Click on that item so that it is checked. Click Ok, to close that box, then close the Properties box. (This may require a re-boot -- don't remember). If you have a Drive D (SDXC card) do the same for it.

    3 - We're back to the "Read Only" issue, and it is not yet clear to me what you expect to be able to do at this point.

    4 - I think we will have solved that problem with Item 2 above.

    5 - In theory, the RT cannot Host a Remote Desktop (RDP)session (You can do it through invitation, but probably not necessary). What you want to do is be able to RDP (yes, that's a verb) from the RT to your Win7 machine. So, on your Win7 machine, open Control Panel/System & Security/System/Remote Settings. Under the Remote tab in that box are some choices. Under Remote Desktop, I suggest the "Allow connections from computers running any version, . . .." If you click on Select Users button, you should find that your user name is already granted access. Close these boxes with the appropriate Apply/Ok instructions.

    6 - "Sharing Tab is missing on the Surface window" -- see #2 above.

    7 - Well, I hope we have solved most of that. Reboot both machines, just for practice, and see what you can do now.

    Good luck.

    Regards,
    Russ
     
    Last edited: Apr 17, 2013
    1 person likes this.
  3. Richard Jones

    Richard Jones Member

    Joined:
    Apr 11, 2013
    Messages:
    30
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    Woking, Surrey, England
    My Device:
    RT
    Hi Russ.

    You really are very kind. Using your numbers:-

    2. Right clicking on C and opening Properties on the Surface shows the usual blue/purple circle about space and tabs for General, Tools, Hardware, Security and Quota but there isn't one for Sharing I'm afraid.

    3. By Read-Only I mean I can read the files but am not allowed to amend them as I would do if I pulled up a file in the normal way on the same PC from, say, Documents. Any amended file has to be saved under Save As with a different name rather than allowing the original to record & retain my amendments.

    5. Tried this. The box is ticked to "Allow Remote Assistance connections to this computer" and under the Advanced Window I have "Allowed computer to be controlled remotely" although the box for "Create invitations that can only be used from computers using Windows Vista and later" remains unticked. I cannot see a User Button I'm afraid.

    I hope I'm not being too dense!

    Regards,

    Richard
     
  4. Russ

    Russ Active Member

    Joined:
    Nov 19, 2012
    Messages:
    600
    Likes Received:
    113
    Trophy Points:
    43
    Location:
    North Georgia, USA
    Hi, Richard --

    Nah, I think I'm the one being dense here. I should have noted earlier that you are using Win7 Home Premium. I have never used that edition, but do recall reading somewhere that Remote Desktop is not included in that edition of Win7. I just confirmed that with an online search, so not sure where we go from here as to Remote Desktop, unless you think it is worthwhile to upgrade to Win7 Pro.

    2 - Back to the Sharing issue on RT. This is what the Properties box looks like on my RT:
    Richard02.png

    Note that one of the tabs is Sharing. I don't know why yours would be different, but maybe there's a shortcut. The Right Click on Windows C, brings up this box:
    Richard01.png

    Note the "Share With" selection. Clicking that gives you a path to Advanced Sharing, which should look like this:
    Richard03.png

    If it does, then click "Share this folder." Then, down further in that box, click "Permissions," in that box, under "Allow," click the little box for "Full Control." Close all boxes with appropriate combinations of Ok/Apply. Again, you my need to reboot for these changes to be effected.

    3 - "Read Only" -- Hopefully solved with last item above.

    Hope those pictures aren't too big, or I'm likely to be scolded for using too much bandwidth.

    Let me know how it works out this time.

    Take care,
    Russ
     
    1 person likes this.
  5. Russ

    Russ Active Member

    Joined:
    Nov 19, 2012
    Messages:
    600
    Likes Received:
    113
    Trophy Points:
    43
    Location:
    North Georgia, USA
    Richard --

    If you're looking for our recent exchange, it's down here now.

    Regards,
    Russ
     
  6. Richard Jones

    Richard Jones Member

    Joined:
    Apr 11, 2013
    Messages:
    30
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    Woking, Surrey, England
    My Device:
    RT
    Hi Russ,

    You really have gone to a great deal of trouble for which I am very grateful but unfortunately I've run into a blank wall with your suggestions.

    R clicking on the C Drive opens exactly the same list as you show save that there is no line for "Share With."

    I've tried opening the Wi-Fi symbol under Settings which opens the list of available connections and then R. clicked on my particular connection which then opens a list itemising "Show estimated data usage, Set as metered connection, Forget this Network, Turn sharing on or off and View connection properties." Opening the "Turn sharing on or off" line I then clicked on the note reading "Yes. Turn on sharing & connect to network devices (for home or work networks)." I might have expected this to lead to the same result as the route you suggested but I remain in exactly the same position as before and as I've already outlined.

    All very mysterious! It's making me wonder if there's something missing from my Surface! I think I may have read somewhere that there is a difference between the US and the UK programmes and wonder if this might be the problem. If so, it might explain why my Contacts list from Windows Live 2011 e-mail failed to open in my People item and why my e-mails don't synchronise with my PC when deleteing items as it does when using my android phone.

    It's a shame about not being able to Remote connect with my version of Windows 7. Thank you for researching that.

    Many thanks again for all that you have done for me.

    Kind regards,

    Richard
     
  7. Russ

    Russ Active Member

    Joined:
    Nov 19, 2012
    Messages:
    600
    Likes Received:
    113
    Trophy Points:
    43
    Location:
    North Georgia, USA
    Richard --

    I searched online for US/UK differences in the RT, but couldn't find anything. I suggest you contact Microsoft on this. Maybe at least you will get an explanation, if not help. Microsoft Surface Answer Desk

    That is a US site. I don't know if there is a different one for the UK, but that would still be a good place to start.

    File sharing is such a basic function that I cannot imagine it would have been intentionally eliminated. There are some others here who are in the UK. Maybe they can shed some light on it.

    Take care,
    Russ
     
  8. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,106
    Likes Received:
    1,724
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    From theSurface I can open the Homegroup and can access documents etc on my PC but onlyin Read-Only mode which makes making any amendment difficult and tiresome. ThePC recognises the existence of the Homegroup but, when I try to open it, itthrows up a message saying that no other Homegroup Devices or Printers areavailable. I have followed the Troubleshooting procedures but I’m afraid thesehave led nowhere. So what I have is a one way Homegroup with only limited use.
    Answer – Windows RT can only be a “File Share Client”, it does not support being a “File Share Host” which means that sharing is unidirectional only. I bought an external hard drive that plugs into my router and all of my home machines can access.

    Clicking on the Network item in the left pane of the Explorer Window on bothmachines identifies both the Surface and the PC. Tapping the PC connection onthe Surface reveals the files on the PC which I can then access but again on aRead-Only basis only. Clicking on the Surface connection in the PC ‘s Windowresults in a message saying that the Surface cannot be accessed. Again theTroubleshooting links have led nowhere.

    Answer – On your Windows 7 Home Machine if you right click the network icon in the lower left corner (next to the clock) andOpen the “Network and Sharing Center” you can click on the Home Group and allowto change the access level so it won’t be “Read Only”
    http://windows.microsoft.com/en-us/windows7/share-libraries-with-your-homegroup

    It follows from all of this that Remote Access Desktop will not work either.

    Answer – Windows 7 Home Premium does not support being a Remote Desktop Host, RT is the same. Both Support being aRemote Desktop Client. You can upgrade your desktop to Windows 7 Pro or Windows8 Pro to get that functionality, or use something like Splashtop or Team Viewerboth available in the Windows 8 store.

    Opening the Change Adapter Settings in the Network and Sharing Centre and thenopening the Local Area Sharing Properties Window shows two tabs on the PC(Network and Sharing) but the Sharing Tab is missing on the Surface windowalthough I have been able to turn sharing on here by right clicking the Wi-Fibutton in the Settings sequence.

    Answer – See above, RT can’t be configured as a“File Share Host”, only a client

    Having only these one-way and limited connections is so frustrating as is myinability to Remote Access from one to the other!

    Answer – Sorry this is by design
     
    1 person likes this.
  9. Russ

    Russ Active Member

    Joined:
    Nov 19, 2012
    Messages:
    600
    Likes Received:
    113
    Trophy Points:
    43
    Location:
    North Georgia, USA
    Jeff --

    Thanks for the clarification, but there is still something amiss with Richard's RT. He is unable to access files on it from his desktop. I can move files from the RT to my desktop; he can't even see them, and there is, apparently, no feature available to allow him to share those files.

    It's a mystery.

    Regards,
    Russ
     
  10. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,106
    Likes Received:
    1,724
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    Most likely when the desktop was joined to the Home Group it was set to Read Only, that is why I added the link to edit the Home Group Settings:)
     
  11. Russ

    Russ Active Member

    Joined:
    Nov 19, 2012
    Messages:
    600
    Likes Received:
    113
    Trophy Points:
    43
    Location:
    North Georgia, USA
    Understand. Thanks, Jeff.
     
  12. Richard Jones

    Richard Jones Member

    Joined:
    Apr 11, 2013
    Messages:
    30
    Likes Received:
    1
    Trophy Points:
    8
    Location:
    Woking, Surrey, England
    My Device:
    RT
    Jeff and Russ,

    Very many thanks to both of you for your contributions, even if the answers are a little disappointing given the OS limitations.

    I bought an external hard drive that plugs into my router and all of my home machines can access.
    I can't find a socket on my router into which I can plug in an extra hardrive but wouldn't Cloud (Skydrive) be just as effective or am I missing something?

    Open the “Network and Sharing Center” you can click on the Home Group and allowto change the access level so it won’t be “Read Only”
    As far as I can see I am allowed access on all settings so I'm afraid this doesn't take me much further forward in trying to deal with the "Read Only" problem.

    Best wishes to you both.

    Richard
     

Share This Page

Search tags for this page

computers not talking to each other

,

how to connect my computer to surface rt network

,

remotely connecting microsoft surfaces to eachother

,

talking with other computer

,

turn off drive sharing on remote desktop