Solved connected to wifi but no internet access

Discussion in 'Microsoft Surface Help' started by Claraw641, Aug 10, 2015.

  1. Claraw641

    Claraw641 New Member

    Joined:
    Aug 10, 2015
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    Surface 3 (Atom)
    I recently got a surface 3 in the mail from the Microsoft store. I absolutely love it, but there's a big issue that's been bugging me.

    Sometimes when I turn on my surface, I can't get on the Internet. It says I am connected to the wifi network, but no internet pages will load. Every other device connected to this network works perfectly. I can't switch networks because my house only has one.

    The only fix I have found for this problem is to turn it off and leave it off for a long period of time. When I turn it back on, it usually works fine. However, I'll need my surface for school in a few weeks and I want to be able to get on the Internet whenever I need it.

    I'm very frustrated and this problem is keeping me from truly enjoying my surface experience. Any help would be greatly appreciated.
     
  2. sharpuser

    sharpuser Super Moderator Staff Member

    Joined:
    Aug 20, 2013
    Messages:
    2,847
    Likes Received:
    1,029
    Trophy Points:
    113
    Location:
    Pacific Northwest & China
    My Device:
    Surface Book
    @Claraw641 ,

    We need to get you some relief.
    You may be having a conflict with the future IPV6 (Internet Protocol Version 6).

    Do this:

    1) Right-mouse click on the WiFi icon
    2) Open Network and Sharing Center
    3) Change Adapter Settings
    4) Right-mouse click on your adapter, Settings
    5) Uncheck the box marked "Internet Protocol Version 6...", OK, exit, etc...
    6) Restart Windows

    If that does not help, then do this:

    1) Right-mouse click on the WiFi icon
    2) Open Network and Sharing Center
    3) Change Adapter Settings
    4) Right-mouse click on your adapter, Disable
    5) Right-mouse click on your adapter, Delete
    6) Restart Windows

    Let us know...

    Screenshot (155).png
     
    Claraw641 likes this.
  3. sharpuser

    sharpuser Super Moderator Staff Member

    Joined:
    Aug 20, 2013
    Messages:
    2,847
    Likes Received:
    1,029
    Trophy Points:
    113
    Location:
    Pacific Northwest & China
    My Device:
    Surface Book
    If you get it working by unchecking the Internet Protocol Version 6... line, try enabling it again. The hardware may be 're-provisioned' to be okay.
     
  4. Claraw641

    Claraw641 New Member

    Joined:
    Aug 10, 2015
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    Surface 3 (Atom)
    @sharpcolorado , thank you so much for your help! Unchecking the IPV6 line worked right away.
     
  5. kayzee

    kayzee Well-Known Member

    Joined:
    May 31, 2013
    Messages:
    2,082
    Likes Received:
    228
    Trophy Points:
    63
    Location:
    Essex, UK
    My Device:
    SPro
    They don't call him 'sharp' for nothing :D
     
  6. Wilock

    Wilock New Member

    Joined:
    Oct 24, 2015
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro3
    Hey all, I am having a similar issue with my wife's SPro3, although our problem has only happened this once and we can't get internet back (although the wifi is connected). It just says "Limited" internet, even though all our other devices (both wired and wireless) are connecting just fine and speed test confirms our internet is performing normally. I have restarted our router, restarted the Surface, and downloaded the newest SurfacePro3_Win10_150915_0 drivers and installed them. Nothing changed. I then followed the instructions in this post to disable IPv6 (+restart). That also didn't work. I then disabled the adapter as instructed, but the option to delete it is greyed out. So, thus far, I'm out of options. Is there anything else I can try?
     
  7. jarodag99

    jarodag99 New Member

    Joined:
    Mar 22, 2016
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro3
    You ever figure this out? My WiFi works great at home but at work it won't allow Internet access (not restricted at all). My Samsung 6e+ connects fine. I've tried the above and no luck. Same issue with not being able to delete adapter also
     
  8. Jvas21

    Jvas21 New Member

    Joined:
    Jun 23, 2016
    Messages:
    2
    Likes Received:
    1
    Trophy Points:
    3
    My Device:
    SPro3
    I am having this same wifi issue however I had no luck using the first fix listed above. When performing the second option on the 5th step, I cannot click on the delete option after right clicking on my adapter. If someone can please help me resolve this issue that would be great.
     
  9. sharpuser

    sharpuser Super Moderator Staff Member

    Joined:
    Aug 20, 2013
    Messages:
    2,847
    Likes Received:
    1,029
    Trophy Points:
    113
    Location:
    Pacific Northwest & China
    My Device:
    Surface Book
    @Jvas21,

    It takes a bit of time (about 1 minute) for an adapter to be disabled, before it can be deleted. Try deleting it again?
     
  10. Jvas21

    Jvas21 New Member

    Joined:
    Jun 23, 2016
    Messages:
    2
    Likes Received:
    1
    Trophy Points:
    3
    My Device:
    SPro3
    I just turned on my surface pro 3 to try again and I noticed that my wifi is functioning properly now. I guess it doesn't always fix right away? Well thank you so much for the solution above!
     
    sharpuser likes this.
  11. sharpuser

    sharpuser Super Moderator Staff Member

    Joined:
    Aug 20, 2013
    Messages:
    2,847
    Likes Received:
    1,029
    Trophy Points:
    113
    Location:
    Pacific Northwest & China
    My Device:
    Surface Book
    Excellent.
     
  12. malcolm341

    malcolm341 New Member

    Joined:
    Sep 16, 2016
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro3
    I'm having the same issue, Surface Pro 3 can't stay connected to wireless network for more than about 5 seconds. My iphone can connect to the wireless network indefinately, the Surface used to be able to connect just fine, then about a year ago it just stopped working.

    I got so mad the other day I clicked the refresh my pc button, highly don't recommend. This reverted my pc back to win 8 and took about a day to get back to win 10 with all the updates.

    It then worked fine and connected to wifi for a couple weeks and now it's broken again, connects to the wifi for about 5 seconds, then goes offline for 15, then connects again for about 5. I have ruled out all variables this is absolutely the Surfrace Pro that is broken because it has the same issue on other wifi networks. I've tried the suggestions here and about 20 other forum posts because this problem is very common, and nothing works. How do I get this device to stay connected to wifi.
     

Share This Page

Search tags for this page
connected to wifi but no internet
,
surface 3 connected to wifi but no internet
,
surface 3 no internet access
,
surface connects to wifi but no internet
,
surface no internet
,
surface pro 3 no internet
,

surface pro 3 no internet access

,
surface pro 3 wifi connected but no internet
,

surface pro 4 no internet

,
surface pro 4 wifi connected but no internet