Disabled connected standby, now sleep no longer an option.

Discussion in 'Microsoft Surface Pro 3' started by supremekizzle, Dec 17, 2015.

  1. supremekizzle

    supremekizzle Member

    Joined:
    Jan 15, 2015
    Messages:
    49
    Likes Received:
    4
    Trophy Points:
    8
    I was sick of having my SP3 die ALL THE TIME when the lid was closed and it should have been using minimal battery so I turned off connected standby, however, normal standby or sleep is no longer an option in power options. Just hibernate. Is this Microsofts way of forcing us to use CS? That is a bunch of BS. Anything I can do to have normal sleep without battery draining connected standby? Sick of getting to school to realize that even though I fully charged my surface and put it in my bag the night before, it's dead. About to throw it at the wall.
     
  2. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,095
    Likes Received:
    1,724
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    That is by design, disable Connected Standby in S4 and S5 (Hibernate and Off) are your only option other than S0 (On). S3 (Sleep) is not supported on the RT, S2, S3, SP3, SP4 and Surface Book.
     
  3. supremekizzle

    supremekizzle Member

    Joined:
    Jan 15, 2015
    Messages:
    49
    Likes Received:
    4
    Trophy Points:
    8
    Seems like an incredibly bad design. I can literally unplug my SP3 after a full charge, close the lid, and ~12 hours later it will have 20% or less battery. I thought this thing is supposed to be a usable device on the go? Not really useful if I'm tethered to a wall outlet all of the time. Going to sell it and get an iPad Pro so I can actually leave my charger at home.
     
  4. leeshor

    leeshor Well-Known Member

    Joined:
    Jun 19, 2012
    Messages:
    5,071
    Likes Received:
    877
    Trophy Points:
    113
    Location:
    Norcross, GA
    My Device:
    SPro4
    I have never had to take my charger, though I've thought about it. Tell it to turn WiFi off while sleeping then adjust the hibernation to 60 minutes. Any time within that 60 minutes it will wake right up, otherwise it will sleep soundly. I just set up a laptop for a customer yesterday and it has the same, (sleep), options or lack thereof as the current Surface devices.

    That's my suggestion as it is working well for all my Surface users though I personally have started just shutting down if I won't use it for an extended period. It only takes 15 seconds to boot up using Hello. I can be that patient.
     
  5. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,095
    Likes Received:
    1,724
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    If on a SP3 you're experiencing that level of drain in CS something is preventing it either missing updates or something installed is preventing it from entering CS.

    Have you checked to see what is preventing it from entering CS.
     
    leeshor likes this.
  6. supremekizzle

    supremekizzle Member

    Joined:
    Jan 15, 2015
    Messages:
    49
    Likes Received:
    4
    Trophy Points:
    8
    How would I check that?
     
  7. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,095
    Likes Received:
    1,724
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    Run from an elevated CMD Prompt

    powercfg -sleepstudy

    It will create a HTML file in System32 called Sleepstudy.html, copy this file to your desktop and open and look at what is draining the battery.
     
  8. supremekizzle

    supremekizzle Member

    Joined:
    Jan 15, 2015
    Messages:
    49
    Likes Received:
    4
    Trophy Points:
    8
    Thanks, I ran the report, but it only gave me today. I'm going to charge it to full and unplug it and run this again tomorrow.
     
  9. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,095
    Likes Received:
    1,724
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    It will only report if Connected Standby is enabled...
     
  10. next_milenium

    next_milenium Member

    Joined:
    Feb 4, 2015
    Messages:
    95
    Likes Received:
    11
    Trophy Points:
    8
    To me, leeshor's recommendation of setting the hibernation time to 60 minutes (I have mine set up to go into hibernation after 30 minutes) is the best solution. I find CS to be not reliable as sometimes it works well while other times it will drain my battery more than an acceptable amount. The inconsistency is hard to deal with.
     
  11. leeshor

    leeshor Well-Known Member

    Joined:
    Jun 19, 2012
    Messages:
    5,071
    Likes Received:
    877
    Trophy Points:
    113
    Location:
    Norcross, GA
    My Device:
    SPro4
    I have been thinking about setting it for 30 minutes. It will probably work fine for me but the 120 minute default is too long imo.
     
  12. Haldi

    Haldi Member

    Joined:
    Nov 27, 2014
    Messages:
    199
    Likes Received:
    15
    Trophy Points:
    18
    My Device:
    SPro3
    Originally it was 4hours before CS was over and Hibernation started, or not?
    AFAIK only with Windows 10 we got the poweroption to choose our own time.

    I have mine on 60Minutes. If I don't use it again after 60 minutes I don't need CS anyway.
     

Share This Page

Search tags for this page

how to disable connected standby on surface pro4

,

surface 4 connected standby off

,

surface connected standby

,

surface pro 3 no sleep option