Displayport connection issue

Discussion in 'Microsoft Surface Pro' started by yellow, Dec 6, 2014.

  1. yellow

    yellow New Member

    Joined:
    Jan 31, 2014
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    I've been using my SP1 for more than 6 months and everything has been working well.
    I recently bought a monitor and it is now connected to it 24/7 with a mini DP to DP cable, but sometimes the image blinks like the the cable is being connected and disconnected every 10 seconds or so, and if i restart windows this issue disappears and it works fine. I think this only happens when waking from sleep/hibernation.
    Searched the net and couldn't find anything similar, does anyone know about this issue?
     
  2. yellow

    yellow New Member

    Joined:
    Jan 31, 2014
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
  3. yellow

    yellow New Member

    Joined:
    Jan 31, 2014
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Anyone with this problem? I still have it happening, even after formatting. Have yet to try on Windows 10.
     
  4. leeshor

    leeshor Well-Known Member

    Joined:
    Jun 19, 2012
    Messages:
    5,071
    Likes Received:
    877
    Trophy Points:
    113
    Location:
    Norcross, GA
    My Device:
    SPro4
    The problem you're having is the same problem some people are having even with no external monitor attached. It's a video driver issue and Intel is supposedly working on a fix.

    If you follow the posts re: display flashing - driver crashing on wakeup from sleep it's the same problem.
     
  5. GreyFox7

    GreyFox7 Super Moderator Staff Member

    Joined:
    Jul 27, 2014
    Messages:
    6,335
    Likes Received:
    1,279
    Trophy Points:
    113
    Just to be sure have you tried replacing the cable or monitor? Can you run the monitor and or cable from another system with the same resolution without issue? From your description I'm not 100% sure that the issue is exactly the same but it might be.
     
  6. yellow

    yellow New Member

    Joined:
    Jan 31, 2014
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    I only tried with another monitor and various tvs but with an hdmi adapter. I dont remember if it also happened but microsoft support told me it is a known issue and theres no solution.
     
  7. yellow

    yellow New Member

    Joined:
    Jan 31, 2014
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    I've since formatted and later updated to W10 and the problem exists like before. Its absurd a company like Microsoft, after acknowledging the problem, offers no solution to such a grave issue that affects daily usability.

    I'm pretty sure it's not the monitor or cable's fault, because if i reboot or log out and log in, the problem disappears
     
  8. ScottyS

    ScottyS Active Member

    Joined:
    Apr 14, 2013
    Messages:
    672
    Likes Received:
    116
    Trophy Points:
    43
    Location:
    New York
    My Device:
    SPro3
    Does it stay good after a reboot, or does it later pop up again?
    I'd try another cable, just to be sure.
     

Share This Page

Search tags for this page

displayport connection issue

,
surface displayport boots disconnected