DisplayPort issue

Discussion in 'Surface 3 (Atom)' started by matro, Jan 6, 2017.

  1. matro

    matro New Member

    Joined:
    Nov 1, 2013
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Yesterday I noticed the DisplayPort of my Surface 3 is no longer working properly: I've tried with two different mDP-DP adapters and three external monitors, both with HDMI and VGA, with same results: as soon as I connect the mDP cable I can hear the new device notification sound, the Display Settings shows two monitors, but if I press 'Identity' both '1' and '2' are shown in tablet's display, pressing 'Detect' shows 'Didn't detect another display', and no output on external monitor.

    I'm sure I was able to use external monitors some months ago, but I didn't try anymore until yesterday.

    Windows 10 has got all the updates so far (up to KB3206632 December 2016), Intel HD Graphics driver version is 20.19.15.4424.

    Is anyone experiencing the same?

    Thank you.
     
  2. martinn1209

    martinn1209 New Member

    Joined:
    Jan 6, 2017
    Messages:
    2
    Likes Received:
    1
    Trophy Points:
    3
    My Device:
    SPro4
    Had the same type of issue with my SP4 a couple of months ago. I supposed it is a physical issue (how often can you connect to these tiny ports? 100x, 1000x?) and used wireless display adapter since. Less quality, hope they get beter equipment over time...
     
  3. hughlle

    hughlle Super Moderator Staff Member

    Joined:
    Jul 7, 2014
    Messages:
    2,741
    Likes Received:
    424
    Trophy Points:
    83
    I've never had a problem other than the plug in, unplug, plug in issue that they sometimes have in order to detect the display correctly. I've not used a second screen with !Y s3 in a long long time, and I'm also on the fast track insider programme, but I'll plug my Dell ultra wide into it tomorrow at some point t and let you know how it goes.
     
  4. matro

    matro New Member

    Joined:
    Nov 1, 2013
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    thank you hughlle, let me know... the issue really seems related to the graphic driver.
     
  5. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,175
    Likes Received:
    1,732
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    Try to find the official HDMI to mDP adapter and see if it works better....
     
  6. matro

    matro New Member

    Joined:
    Nov 1, 2013
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    I just tried with latest January 2017 cumulative update KB3213986 with no luck, the issue is still there.
     
  7. hughlle

    hughlle Super Moderator Staff Member

    Joined:
    Jul 7, 2014
    Messages:
    2,741
    Likes Received:
    424
    Trophy Points:
    83
    Sorry it took so long to get back to you, work...

    I've just plugged in my dell ultrwide via mDP->mDP and it worked instantly without an issue.

    For reference I am on windows build 14986 (insider build) and my graphics driver is the same as yours, 20.19.15.4424
     
  8. matro

    matro New Member

    Joined:
    Nov 1, 2013
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    thank you for the test, @hughlle. at this point I should try a reset and see how it goes.
     

Share This Page