Docking station losing network connectivity

Discussion in 'Microsoft Surface Pro 3' started by doctormeatusa, Jul 13, 2015.

  1. doctormeatusa

    doctormeatusa New Member

    Joined:
    Feb 4, 2013
    Messages:
    4
    Likes Received:
    2
    Trophy Points:
    3
    Location:
    Champaign, Illiniois
    My Device:
    SPro3
    Over the past three weeks I have had several occasions where my Ethernet connectivity has quit through the docking station. I read in another thread about docking station issues that power cycling the docking station would help - and it does - the connection comes right back every time.

    But over the past few days, it has happened repeatedly. Also, normally I am able to use web video conferencing and screen shares (GotoMeeting) without throughput issues, but not today. I've checked our office's routers and outbound connection and everything is fine.

    Has anyone else experienced this? I'm on the latest Win10 build, but haven't seen anything on that thread about this issue.
     
  2. wditters

    wditters Active Member

    Joined:
    Feb 1, 2014
    Messages:
    149
    Likes Received:
    32
    Trophy Points:
    28
    Location:
    Amsterdam
    My Device:
    SPro3
    See my other post. Try installing the Realtek RTL8153/8152/GBe drivers from www.station-drivers.com. Works flawlessly now :)
     

Share This Page

Search tags for this page

loosing wifi connection surface docking

,

surface dock loses network connection

,

surface pro 3 losing network connection when on a docking station

,

surface pro 4 losing ethernet connection

,

why do i lose connection when i to docking station

,

windows surface docking station losing network connection