Elusive on screen keyboard

Discussion in 'Microsoft Surface Pro' started by MMU, Apr 29, 2013.

  1. MMU

    MMU Member

    Joined:
    Feb 28, 2013
    Messages:
    56
    Likes Received:
    3
    Trophy Points:
    8
    Location:
    Anacortes, WA
    Browsing the Web with the new IE in tablet mode, when touching a text entry window in some forums (such as to post a message in a forum) brings up the on-screen keyboard. However, it immediately disappears before it can be used. I've seen this issue posted previously but I could not find it with a search and I don't remember what the resolution was.

    The only work-around I've discovered is to use the stylus to select a small bit of text in the window (the OSK pops up) and then touching the text to deselect and get back to the text entry cursor. The OSK will now stay deployed and ready to use.

    This is not a very good work-around.

    Help!
     
  2. ArnoldC

    ArnoldC New Member

    Joined:
    Nov 26, 2012
    Messages:
    1,537
    Likes Received:
    110
    Trophy Points:
    0
    Location:
    Makati, Philippines
    I posted a video on how you can get around it... no stylus needed. It may be buried in the forums :(
     
  3. Sin

    Sin New Member

    Joined:
    Nov 14, 2012
    Messages:
    470
    Likes Received:
    32
    Trophy Points:
    0
    Location:
    Connecticut, USA
    My Device:
    RT
    I was also not able to find the video ArnoldC posted, but it's around here somewhere. The other options are to change your default editor in the forum under Settings - General Settings - Message Editor Interface to Enhanced WYSIWYG and the on-screen keyboard should behave better or you set the forum to display in compatibility mode in IE, but that has a horrible visual side effect where the user information that is supposed to be displayed to the left of the user's post is displayed above and across the whole screen. Using the Enhanced editor leaves you unable to insert line breaks directly in the forum response (you can paste from another application) and using comparability mode is causes the forums to display in an unusual manner.

    Hope the helps.
     
  4. MMU

    MMU Member

    Joined:
    Feb 28, 2013
    Messages:
    56
    Likes Received:
    3
    Trophy Points:
    8
    Location:
    Anacortes, WA
    Thanks! Changing to WYSIWYG did fix my problems. I was not able to locate Arnold's video and don't know what it depicts.
     
  5. ArnoldC

    ArnoldC New Member

    Joined:
    Nov 26, 2012
    Messages:
    1,537
    Likes Received:
    110
    Trophy Points:
    0
    Location:
    Makati, Philippines
    I remember where I stored it... vimeo :D

    [video=vimeo;56617041]https://vimeo.com/56617041[/video]
     
  6. MMU

    MMU Member

    Joined:
    Feb 28, 2013
    Messages:
    56
    Likes Received:
    3
    Trophy Points:
    8
    Location:
    Anacortes, WA
    Thanks Arnold. After using the WYSIWYG method I've realized it might not be the solution I thought it was because, using the WYSIWYG mode, a <CR> (Enter) does not advance the cursor to the next line.

    But I am having trouble getting the method shown in the video to work also.

    This is frustrating. Can't Microsoft come up with a simple patch to fix this?
     
  7. ArnoldC

    ArnoldC New Member

    Joined:
    Nov 26, 2012
    Messages:
    1,537
    Likes Received:
    110
    Trophy Points:
    0
    Location:
    Makati, Philippines
    It is a vBulletin issue, not Microsoft.

    Please change forum settings accordingly: Settings - General Settings - Standard Editor.
     
  8. MMU

    MMU Member

    Joined:
    Feb 28, 2013
    Messages:
    56
    Likes Received:
    3
    Trophy Points:
    8
    Location:
    Anacortes, WA
    But with the standard editor I have the same issue depicted in your video.
     
  9. ArnoldC

    ArnoldC New Member

    Joined:
    Nov 26, 2012
    Messages:
    1,537
    Likes Received:
    110
    Trophy Points:
    0
    Location:
    Makati, Philippines
    Setting it to Standard Editor allows the use of Enter.
     
  10. MMU

    MMU Member

    Joined:
    Feb 28, 2013
    Messages:
    56
    Likes Received:
    3
    Trophy Points:
    8
    Location:
    Anacortes, WA
    I see what you are saying but I need to use "Enter" for <CR> AND I need the on-screen keyboard. I don't think it's acceptable to have to switch between two different editor modes just to make a simple post.
     
  11. machistmo

    machistmo Active Member

    Joined:
    Nov 17, 2012
    Messages:
    790
    Likes Received:
    53
    Trophy Points:
    28
    Location:
    Raleigh NC
    My Device:
    Other
    I use it in Desktop mode and compatibility mode so that I can post both paragraphs and pictures. That way I can just click the keyboard icon in the systray area.
     
    1 person likes this.
  12. ArnoldC

    ArnoldC New Member

    Joined:
    Nov 26, 2012
    Messages:
    1,537
    Likes Received:
    110
    Trophy Points:
    0
    Location:
    Makati, Philippines
    @mmu, And I achieved both obviously.
    Sent from my Windows Phone 8S by HTC using Board Express
     

Share This Page

Search tags for this page
microsoft surface no onscreen keyboard login
,
microsoft surface pro 2 bitlocker screen no keyboard
,
new surface keyboard bitlocker issues
,
no onscreen keyboard surface bitlocker
,
surface keyboard bitlocker
,
surface osk handwriting disappears
,
surface pro 2 bitlocker keyboard issue
,

surface pro 2 how to get on-screen keyboard during bit locker

,
surface pro 2 with bitlocker keyboard does not work
,

surface pro 3 osk