Enable virtualisation, so easy you wont believe it.

Discussion in 'Surface 3 (Atom)' started by gammanone, Jun 9, 2015.

  1. gammanone

    gammanone New Member

    Joined:
    May 23, 2015
    Messages:
    13
    Likes Received:
    2
    Trophy Points:
    3
    My Device:
    Surface 3 (Atom)
    Found this on another forum and thought I'd post it here.



    Turns out it was so simple it was downright stupid.
    I was put onto the idea on another forum.

    When I did it my thoughts were "This is so stupid, how did it do that?"

    That is why I didn't post the solution straight away.

    I wanted to make sure it wasn't a fluke, and reboot the Surface a few times and then run the battery completely flat to make sure the setting stuck.

    The steps are

    Step 1
    Install AMIDuOS (An Android Emulator)
    Trial version is ok as that is what I used today.

    Step 2
    Run it, you will get the error about VT being disabled.
    Leave it running and play around with it for 5 minutes.

    Step 3
    Shut it down, and reboot your Surface 3.

    When you boot back up Firmware support for VT will now be enabled.
    Run CheckSLAT or some similar program to confirm and you still see hardware assisted virtualization is now enabled.

    Now I am sure you are thinking that I am bullshitting here.
    And I completely understand why as what I have posted here sounds crazy.

    But that is honestly all I did to enable hardware assisted virtualization on my Surface 3.

    I ran CheckSLAT before I started and it confirmed that VT support was in the CPU but disabled in Firmware.
    And after doing the steps CheckSLAT reported VT all enabled.

    I don't know what AMIDuOS does, but somehow it flips the registry bit in the UEFI firmware to enable VT instructions. (I knew it was only a single bit that need to be flipped but I didn't know how to achieve it until now)

    AMIDuOS should not be able to achieve it but somehow it does it.

    The other question is if you want to is how would you disable it again.
    That I have no idea on, but in reality it doesn't matter anyway if VT is enabled and just not used so it is an academic question.

    EDIT:
    I will add though I would not recommend using Hyper-V as your Hypervisor even though you now can.

    Installing Hyper-V disables some of the more advanced low power states and standby states so will effect your battery life.
    There are other Virtual Machines though that do not have this issue. (I use VMWare for example)
     
    cliffr39 likes this.
  2. jace88

    jace88 Member

    Joined:
    Jun 4, 2015
    Messages:
    47
    Likes Received:
    1
    Trophy Points:
    8
    My Device:
    Surface 3 (Atom)
    i confirmed that this worked for me using the same method.

    (lol i actually am one of the subsequent posters in that same thread/forum you got that from)
     
  3. ynohtna

    ynohtna Member

    Joined:
    May 27, 2014
    Messages:
    139
    Likes Received:
    7
    Trophy Points:
    18
    My Device:
    SPro3
    My surface 3 is the test bed for whatever comes in the windows OS world before I put it on my surface pro 3 :D So it's a physical virtual lol ;D

    What kind of VM would you install on a surface 3 anyways? Why bog it down anymore?
     
  4. jace88

    jace88 Member

    Joined:
    Jun 4, 2015
    Messages:
    47
    Likes Received:
    1
    Trophy Points:
    8
    My Device:
    Surface 3 (Atom)
    Android evidently :) I'm personally running it just so I can play my Clash of Clans village :)
     
  5. ynohtna

    ynohtna Member

    Joined:
    May 27, 2014
    Messages:
    139
    Likes Received:
    7
    Trophy Points:
    18
    My Device:
    SPro3
    Interesting, works well?
     
  6. netuser

    netuser Member

    Joined:
    Feb 23, 2013
    Messages:
    319
    Likes Received:
    13
    Trophy Points:
    18
    How to do undo this when you want to re-enable connected standby?
     
  7. Nghiem

    Nghiem New Member

    Joined:
    Jun 23, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    Surface 3 (Atom)
    Anyone notice that after new update installed virtualization went to disable? Enable virtualization may not support by MS, why?
     
  8. jace88

    jace88 Member

    Joined:
    Jun 4, 2015
    Messages:
    47
    Likes Received:
    1
    Trophy Points:
    8
    My Device:
    Surface 3 (Atom)
    Works fine for CoC. Probably not as smooth as playing it natively on my iPad Air/Galaxy Tab S though but it's definitely fine.

    In terms of under the new firmware, I only just did the update last night and haven't checked how it goes. Hopefully it still runs smooth!
     
  9. momentarydogma

    momentarydogma New Member

    Joined:
    Sep 6, 2015
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    Surface 3 (Atom)
    I don't know if maybe some recent update changed something or not, but I have tried this method a number of different ways after seeing it work for people on various forums, but no matter what I do, virtualization is never enabled. On another forum, I saw someone who said that this could be done by installing VirtualBox then creating a VM, but that did nothing for me. My original intent was so that I could run AmiDuOS, but I have installed apps on Lollipop under that program, run them, messed around with stuff for hours, but rebooting my Surface 3 still shows that virtualization is disabled. Any ideas?
     
  10. fsma

    fsma New Member

    Joined:
    Dec 8, 2015
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    Surface 3 (Atom)
    Hi,

    I'm running Windows 10 64-bit Home edition on my Surface 3 and the above method confirmed working - please see below.

    FYI my Windows 10 is updated with the latest MS updates and I'm using Lollipop VM from Ami Duos. Thanks very much for the fantastic tips.

    upload_2015-12-8_19-10-3.png
     
  11. SomeoneOnLine

    SomeoneOnLine New Member

    Joined:
    Dec 6, 2015
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    Surface 3 (Atom)
    I tried this method several times on my surface 3 atom running W10 home and had zero luck. Are there any other ways of enabling virtualization on the surface 3 atam? Is the latest ms firmware update blocking this method?
     
  12. wAi_PaYnE

    wAi_PaYnE New Member

    Joined:
    Jan 2, 2016
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    Surface 3 (Atom)
    That should work:

    Open cmd as admin and Type:

    bcdedit /set hypervisorlaunchtype auto

    Reboot

    Now Vt should be activate if you follow the steps in this thread.

    Maybe in new firmware MS set it to "off" instead of "auto".
     

Share This Page

Search tags for this page
enable hardware virtualization surface 3 windows 10
,

enable virtualization surface 3

,

how to enable vt on surface 3

,
howto enable intel vt surface pro 3
,

surface 3 enable virtualization

,

surface 3 virtualization

,

surface 3 vt-x

,
surface pro 4 enable hardware hypervisor
,
surface pro hypervisor
,
turn hypervisor on surface pro 4