External USB 3.0 Hardrive (seagate 1tb) Problems

Discussion in 'Surface 3 (Atom)' started by Zippy0n, Nov 18, 2015.

  1. Zippy0n

    Zippy0n Member

    Joined:
    May 21, 2015
    Messages:
    85
    Likes Received:
    11
    Trophy Points:
    8
    My Device:
    SPro4
    Tried having an External Hardrive 3.0 but it keeps on disconnecting/connecting all of the time, at first it was clear that it was a power surge so now I have the surface dock with a Y cable to give a power supply to the Hardrive so it cant be power, it just randomly disconnects even nothing is happening

    Some people seem to suggest turning off the windows USB 'Sleep' feature in Device Manager but there is no such option on the surface.

    Any ideas?
     
  2. hughlle

    hughlle Super Moderator Staff Member

    Joined:
    Jul 7, 2014
    Messages:
    2,691
    Likes Received:
    422
    Trophy Points:
    83
    I can't comment on the seagate drive, but i use a 1tb WD passport drive with my S3 and it works absolutely fine, have not had to change any setting or use a y splitter etc.
     
  3. GreyFox7

    GreyFox7 Super Moderator Staff Member

    Joined:
    Jul 27, 2014
    Messages:
    6,331
    Likes Received:
    1,279
    Trophy Points:
    113
    What is the model of the external drive? Does it have a separate power input (usually round plug)?

    From your description it behaves like it's not getting enough power or it's intermittent. Any chance the Y cable is bad? Can you try a powered USB hub? Use a quality (Anker) USB cable.

    Any other drives available to help isolate if its perhaps the Port, or the Drive?

    Does this drive work correctly on another computer using the same cable?
     
  4. jrioux

    jrioux Active Member

    Joined:
    Dec 12, 2013
    Messages:
    378
    Likes Received:
    46
    Trophy Points:
    28
    Location:
    California's Central Coast
    My Device:
    SPro3
    I agree with GreyFox. I regularly use a Toshiba 1TB drive with my SP3. It works fine when directly connected to the Surface, but never when connected through a USB port. I haven't tried a powered USB port since I now use a BT mouse and don't need to connect two USB devices to the Surface.
     
  5. Zippy0n

    Zippy0n Member

    Joined:
    May 21, 2015
    Messages:
    85
    Likes Received:
    11
    Trophy Points:
    8
    My Device:
    SPro4
    Its a Seagate 1TB ultra slim back up plus - strangely it was working fine when transferring files etc, however when idle it tends to disconnect/connect.

    Hmmmmm
     
  6. Argus Tuft

    Argus Tuft Member

    Joined:
    Dec 16, 2015
    Messages:
    81
    Likes Received:
    2
    Trophy Points:
    8
    My Device:
    Surface 3 (Atom)
    I use a Seagate 2TB portable HDD with my S3, and have never had a problem. I have back-ups, software installation files, music and downloaded movies, and not once has it caused a problem.
     

Share This Page

Search tags for this page

seagate hardrive surface pro 3 power surge when i plug 2 hard drives into usb splitter anker