Solved Firmware update failure

Discussion in 'Microsoft Surface Pro 4' started by adamik_22, Dec 11, 2016.

  1. adamik_22

    adamik_22 New Member

    Joined:
    Dec 11, 2016
    Messages:
    7
    Likes Received:
    1
    Trophy Points:
    1
    My Device:
    SPro4
    Hello.
    I've got this problem of firmware update failing on restart. I get message of "Please wait while we install a system update" but just for split second, then it goes blank and restarts two more times or it goes blank and I need to play with power button or power and volume up button to bring it back. On restart in device manager I can see 5 elements (in section "Firmware" - as on attached screenshot) with exclamation marks, all have code 14 which asks for restart to finish installation, but scenario repeats itself on restart. I've followed instructions of Microsoft team to do different type of restarts, and uninstalling drivers and manually installing them again, plus I've wiped clean windows with the "Reset this PC" feature, but still no joy. I've also check setupapi.dev log but can't find any failures beside:

    MoveFile: 'C:\WINDOWS\system32\drivers\SETB56D.tmp' to 'C:\WINDOWS\system32\drivers\RTKVHD64.sys' FAILED!

    but maybe the log got wiped with windows reset.

    Is there any other way to update that firmware, maybe through deployment kit?

    I'll appreciate any input.
     

    Attached Files:

  2. GreyFox7

    GreyFox7 Super Moderator Staff Member

    Joined:
    Jul 27, 2014
    Messages:
    6,894
    Likes Received:
    1,385
    Trophy Points:
    113
  3. sinha.sandy

    sinha.sandy New Member

    Joined:
    Oct 10, 2016
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro4
    Remove any anti virus from the device and try again. It will be ok

    Sent from my ONEPLUS A3003 using Tapatalk
     
  4. adamik_22

    adamik_22 New Member

    Joined:
    Dec 11, 2016
    Messages:
    7
    Likes Received:
    1
    Trophy Points:
    1
    My Device:
    SPro4
    I've got no anti virus beside the built in Windows Defender.
     
  5. sinha.sandy

    sinha.sandy New Member

    Joined:
    Oct 10, 2016
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro4
    Stop that too. I also had problems with updates, then I uninstalled all these antiviruses, then it updated successfully.

    Sent from my ONEPLUS A3003 using Tapatalk
     
  6. adamik_22

    adamik_22 New Member

    Joined:
    Dec 11, 2016
    Messages:
    7
    Likes Received:
    1
    Trophy Points:
    1
    My Device:
    SPro4
    I've tried already with downloading and installing firmware manually and it did not work. Two buttons restart done few times, but not sure if doing it correctly as always end up in UEFI.
     
  7. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,940
    Likes Received:
    1,880
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Other
    Do you have Hyper-V enabled or Visual Studio installed? Or are you using a VHD on an SD Card? The error is from the Virtual Hard Disk Driver...
     
  8. adamik_22

    adamik_22 New Member

    Joined:
    Dec 11, 2016
    Messages:
    7
    Likes Received:
    1
    Trophy Points:
    1
    My Device:
    SPro4
    I've disabled it through group policy, but still no joy, the good thing is it seems to power down without a crash on restart but crashes on power up when "Please wait while we install a system update" appears, than restarts two more times and boots.

    I got code 10 on those firmware errors after resetting Windows, but after installing firmware manually it shows code 14.

    Any other suggestions?
     
  9. adamik_22

    adamik_22 New Member

    Joined:
    Dec 11, 2016
    Messages:
    7
    Likes Received:
    1
    Trophy Points:
    1
    My Device:
    SPro4
    It's freshly reset windows 10 and I did not install Visual Studio nor I can find it within programs and features. There is no SD card in the slot. And from the attached screen you can see it's not turned on. I'll check UEFI as well, but I don't recall an option like that in there.
     

    Attached Files:

  10. sinha.sandy

    sinha.sandy New Member

    Joined:
    Oct 10, 2016
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro4
    You can do one thing is that download the full factory image from the Microsoft site and reset the device.

    Sent from my ONEPLUS A3003 using Tapatalk
     
  11. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,940
    Likes Received:
    1,880
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Other
    What version of Windows are you running? 1511 or 1607?
     
  12. adamik_22

    adamik_22 New Member

    Joined:
    Dec 11, 2016
    Messages:
    7
    Likes Received:
    1
    Trophy Points:
    1
    My Device:
    SPro4
    It was my plan to try when deplete all the option, and yes, it worked. I've done full wipe of the drive as well. Something terrifying happened and I'm not sure if it was suppose to; on updating firmware when third progress bar was filling up cpu started overheating and fan was working like mad and machine suddenly cut off. I couldn't have turned it on for next 5 minutes, longest 5 minutes ever, as this sp4's warranty is expired (bought it of ebay). When it finally started back up it finished remaining updates, going hot on the last one again :eek: but this time when it shut down it restarted straight back up. So, so far so good. Just doing normal updates now. Thanks everyone for input. I think I can close this thread as solved.
     

Share This Page

Search tags for this page
firmware update stuck please wait while we install a system update
,

fui resetat windows 10 e travou na tela please wait while we install a system update

,
surface pro 5 stop at please waite while we install a system update