Solved Fonts in Illustrator Not Working Properly

Discussion in 'Microsoft Surface General Discussion' started by Tino, Aug 26, 2017.

  1. Tino

    Tino New Member

    Joined:
    Aug 26, 2017
    Messages:
    2
    Likes Received:
    2
    Trophy Points:
    3
    My Device:
    Surface Book
    Dear all,

    I was wondering if you guys having the same issue as me. I currently use the latest AI CC downloaded directly from Adobe with full license. The same software I have been using for over one year on my laptop, everything is fine and perfect.

    But when I install it in my Surface 2017, and only in illustrator (photoshop is fine) does the fonts appear like this:
    [​IMG]
    It's like in the same AI file, but the display in touch AI of Surface 2017 is different than the display in other devices. I check the result to see if it's just the display and it results fine. Even when I think the problem is of the touch version of AI, I changed it back to normal AI function on my Surface 2017 but the fonts still display like that. I know if the results are the same then I don't have anything to worry about but because of my designing work I need to have it clear and transparent, not shaky blurry or unidentified like this. Please help if anyone having the same issue as me!
     
  2. oldsock

    oldsock New Member

    Joined:
    Mar 6, 2013
    Messages:
    12
    Likes Received:
    8
    Trophy Points:
    3
    I've experienced the same thing. Go into your preferences and turn off GPU acceleration. It has something to do with Illustrator and the Intel Graphics GPU. Just switch to CPU preview to check it out before changing your settings and you'll see everything shows up fine.

    Sent from my SM-T820 using Tapatalk
     
  3. Tino

    Tino New Member

    Joined:
    Aug 26, 2017
    Messages:
    2
    Likes Received:
    2
    Trophy Points:
    3
    My Device:
    Surface Book
    Thank you for your reply. I have successfully fix my case. For new comers, the new window 10 update doesn't support switching GPU acceleration on sight or in window display or in window properties or anything. To fix GPU accelerator for Surface we need to do it inside Illustrator in Preferences > GPU accelerator > Uncheck Animated Zoom. Thank you all!
     
    fivetoedsloth and sharpuser like this.
  4. sharpuser

    sharpuser Super Moderator Staff Member

    Joined:
    Aug 20, 2013
    Messages:
    3,355
    Likes Received:
    1,103
    Trophy Points:
    113
    Location:
    Pacific Northwest & China
    My Device:
    Surface Book
    Thanks, @oldsock for the solution, and @Tino for the post and summary. Marking solved.
     

Share This Page