For those who have trouble with SSL VPN

Discussion in 'Microsoft Surface Pro' started by Uncensored2008, Feb 27, 2013.

  1. Uncensored2008

    Uncensored2008 Member

    Joined:
    Feb 26, 2013
    Messages:
    74
    Likes Received:
    7
    Trophy Points:
    8
    Location:
    California
    The Surface Pro is a 64 bit machine with a 64 bit OS. For a couple of people I've encountered, this has presented a problem in setting up an SSL VPN. (If you don't know what that is, go ahead and ignore the rest of this post.)

    With Cisco, Palo Alto, WatchGuard, and Sonicwall, the basic rule is "64=64." What this means is that on a 64 bit OS, you must use IE 64 and a 64 bit Java. The challenge is instantly apparent, since there is no 64 bit Internet Explorer on the SP, by default.

    But fear not, a work around is very simple.

    First, do a manual install of Java JE 64 bit Download Java for Windows
    Then you need a 64 bit browser. Google Chrome fits the bill. Chrome automatically recognizes the 64 bit OS and installs the correct version.

    These simple steps should have you happily slaving away on company business at the beach, kids birthday parties, your honeymoon, or wherever. http://www.surfaceforums.net/forum/images/smilies/biggrin.png
     
  2. ArnoldC

    ArnoldC New Member

    Joined:
    Nov 26, 2012
    Messages:
    1,537
    Likes Received:
    110
    Trophy Points:
    0
    Location:
    Makati, Philippines
    You are misinformed.
     
  3. malberttoo

    malberttoo Super Moderator Staff Member

    Joined:
    Feb 26, 2013
    Messages:
    2,255
    Likes Received:
    428
    Trophy Points:
    83
    Location:
    Alaska
    My Device:
    SPro3
    Also, my 64-bit Cisco VPN client has never had a problem regardless of what my IE or Java was doing.

    I'll have to research your issues a little more.


    -Michael
     
  4. Uncensored2008

    Uncensored2008 Member

    Joined:
    Feb 26, 2013
    Messages:
    74
    Likes Received:
    7
    Trophy Points:
    8
    Location:
    California
    I'm not having any issues, the VPN is working flawlessly. I'm just sharing with those who do have problems the way to solve them. I ran into TWO people this week who complained that they could not get their SSL VPN to work, the opening post solved both. One was connecting to a Cisco and the other Sonicwall.

    If you're having no problems, great. But this might help those who are having issues.
     
    1 person likes this.
  5. Cowboy

    Cowboy New Member

    Joined:
    Feb 17, 2013
    Messages:
    62
    Likes Received:
    8
    Trophy Points:
    0
    From the mouth of Microsoft:

    "On 64-bit Windows 8, the browser frame process (both “modern UI” and Desktop) runs 64-bit. However, for compatibility with plug-ins, IE 10 on the desktop runs 32-bit tabs by default. If the user turns on “Enhanced Protected Mode” in Internet Options, Advanced; they will have 64-bit tabs by default for IE 10 on the Desktop."

    And the above is further verified by process explorer. If you start IE and then open a couple of tabs you will see that the base (core) process runs in 64 bit and all the tab processes run in 32 bit.
     
    3 people like this.
  6. Soylent

    Soylent New Member

    Joined:
    Feb 26, 2013
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    0
    Location:
    Florida, USA
    No problems using Cisco Anyconnect without Java or IE. Are you sure you have the latest version of the VPN client?
     
  7. jgatwood

    jgatwood New Member

    Joined:
    May 17, 2013
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    OpenVPN

    Thank you for the suggestions. I am trying to get OpenVPN (using OpenVPN GUI or Securepoint OpenVPN client) running on a Surface Pro. I followed your suggestions and the only message I get is "an error has occurred". Nothing in the log files. Do you think this is related to the client software or is there an issue with the Surface Pro hardware/TAP driver that is causing the issue. My OpenVPN profile is set to use UDP. Both the OpenVPN GUI and the Securepoint client work fine in Windows 7. Any suggestions would be appreciated. I had also opened a thread in the OpenVPN forum about two weeks ago but no responses yet.
     
  8. vinumsv

    vinumsv New Member

    Joined:
    Mar 20, 2013
    Messages:
    84
    Likes Received:
    10
    Trophy Points:
    0
    Location:
    India
    hmm Try "Run As Administrator" option also i heard some versions of OpenVPN client doesn't work properly in Win8 64bit :sorry:
     
  9. starLog

    starLog New Member

    Joined:
    Jan 12, 2013
    Messages:
    59
    Likes Received:
    0
    Trophy Points:
    0
    I use Juniper Pulse, and have no issues.
     
  10. DOS

    DOS Active Member

    Joined:
    Apr 8, 2013
    Messages:
    145
    Likes Received:
    36
    Trophy Points:
    28
    Location:
    USA
    Thanks for that info...
     
  11. machistmo

    machistmo Active Member

    Joined:
    Nov 17, 2012
    Messages:
    790
    Likes Received:
    53
    Trophy Points:
    28
    Location:
    Raleigh NC
    My Device:
    Other
    I had to install the latest IPSEC client from Fortinet to get my VPN function restored. I only hope that the powers that be will decide to ditch Fortinet for something better in the near future. In the mean time I use the 5.0.2.225 client with all the garbage and baggage I don't need disabled. The SSL cause the Surface Pro to hard-lock and :( screen a lot. Without fail actually. It is MEH at best, but works for now.
     

Share This Page

Search tags for this page
cisco ssl vpn ie10
,
sonicwall ssl vpn ie10
,
sonicwall ssl vpn internet explorer 10
,
sonicwall surface rt
,

sonicwall vpn for surface rt

,

sonicwall vpn surface rt

,
ssl vpn ie 10
,
surface rt palo alto vpn
,

surface rt sonicwall vpn

,
watchguard vpn surface rt