High/strange CPU idle clock frequency

Discussion in 'Microsoft Surface Pro 4' started by AndyK, Feb 26, 2016.

  1. AndyK

    AndyK New Member

    Joined:
    Jan 6, 2016
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    Other
    Hi

    I bought a SP4 last Tuesday, and I really like it.
    However, I'm worried about the high CPU idle frequencies I'm experiencing.
    The first time I noticed it (and the first time I checked) was after updating the original install with 17/2 firmware update: My CPU would idle almost constantly above 1 GHz with only occasional negative spikes to ~0.8 GHz. This at times where network utilization is 0%, disk utilization at 0% and CPU utilization 0-1%.
    I also noticed that touching the touchpad or screen reduced the clock speed: Moving the finger quickly across the screen would sometimes reduce the clock speed to ~0.5 GHz.

    I reset the SP4 and looked at the idle frequency before installing the 17/2 update. My surface was idling below 1 GHz all the time. I then proceeded to install the update and sure enough - the surface was idling above 1 GHz again.

    I then made a recovery USB drive and tried using that but to no avail - now the computer was idling above 1 GHz even before updating. And this is with the same low utilization as explained above.

    The behaviour where using the touchpad or touch screen lower the idle frequency prevails.
    Also the frequency drops (although the utilization increases slightly) when playing youtube videos.
    I then noticed that the idle frequency actually decreases (although with a higher utilization) when idling while showing the edge browser than when showing the desktop.

    Are any of you experiencing the same?
    Do you know if this somehow related to the new speedshift on Skylake where the processor can change the frequency much faster than previous processors?

    Thanks in advance
     
  2. leeshor

    leeshor Well-Known Member

    Joined:
    Jun 19, 2012
    Messages:
    5,071
    Likes Received:
    877
    Trophy Points:
    113
    Location:
    Norcross, GA
    My Device:
    SPro4
    Welcome to the forum

    Windows does some background maintenance tasks and you may be interrupting them. I don't thing you have had or used your Surface long enough without fiddling with it for it to catch up. ;);)
     
  3. Philtastic

    Philtastic Active Member

    Joined:
    Jan 4, 2014
    Messages:
    380
    Likes Received:
    75
    Trophy Points:
    28
    Location:
    Canada
    My Device:
    SPro4
    Yeah, what leeshor said. There are a number of background tasks that need to do things over the first couple of hours and some times after certain updates. Give it a bit of time before you go crazy tweaking things.
     
  4. Yillbs

    Yillbs Member

    Joined:
    Jan 20, 2016
    Messages:
    84
    Likes Received:
    11
    Trophy Points:
    8
    My Device:
    SPro3
    turn off windows defender, see if that helps any. It's likely indexing your files, and scanning in the background. This in addition to what the others have said. Windows Defender has proved useless for me, i'll scan it once in a while when I feel it needed.
     
  5. AndyK

    AndyK New Member

    Joined:
    Jan 6, 2016
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    Other
    Hi Thank you all for the replies.

    I understand that various backgrounds tasks might be what's causing the high idle frequency, byt that does not explain that why playing youtube videoes, using the touchpad (or screen) or idling showing showing edge rather than the desktop yields lower CPU frequencies.

    Can all of you confirm that you have idle frequencies way lower than 1 GHz when doing nothing and idling on the desktop?

    Thanks.
     
  6. Yillbs

    Yillbs Member

    Joined:
    Jan 20, 2016
    Messages:
    84
    Likes Received:
    11
    Trophy Points:
    8
    My Device:
    SPro3
    No one can confirm this, as no OS is the same, installed files / apps / games, etc can control this. The only way to ensure that you're always below 1Ghz is to manually set the CPU frequency, I do, and if i need to use more, I just change the power profile.
     
  7. leeshor

    leeshor Well-Known Member

    Joined:
    Jun 19, 2012
    Messages:
    5,071
    Likes Received:
    877
    Trophy Points:
    113
    Location:
    Norcross, GA
    My Device:
    SPro4
    When you start doing something, Windows suspends the background tasks it was performing to devote it's time to you. Makes perfect sense.
     
  8. fsmith3x

    fsmith3x New Member

    Joined:
    Jul 11, 2014
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    Andy, I've discovered the same problem you are having. My Surf Pro3 always idled below 1ghz so I'm also wondering if this is just a difference in CPUs.
    Were you able to find a solution, or have you given up?
     

Share This Page