Horrible Pixelation on youtube and video playback apps?

Discussion in 'Microsoft Surface Pro 2' started by manoroid, Jun 3, 2014.

  1. manoroid

    manoroid Member

    Joined:
    Jan 20, 2014
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    I have done and tried everything. Everything from full system restore to install / uninstall. I don't remember the picture quality ever being this bad. Any ideas would be greatly appreciated. I did attach a pic up my current driver.

    Thanks
     

    Attached Files:

  2. jefhart

    jefhart Member

    Joined:
    Jan 2, 2014
    Messages:
    181
    Likes Received:
    6
    Trophy Points:
    18
    Location:
    Cincinnati
    My Device:
    SPro2
    Could you post a pic of your youtube?
     
  3. Philtastic

    Philtastic Active Member

    Joined:
    Jan 4, 2014
    Messages:
    380
    Likes Received:
    75
    Trophy Points:
    28
    Location:
    Canada
    My Device:
    SPro4
    I am going to ask some very obvious questions that you have probably tried already but I ask because Youtube is very finicky.
    1) Did you manually set the resolution higher than the default 360p resolution?
    2) Did you rewind the video after setting the resolution to get Youtube to actually change the resolution? Often it will not because it's busy streaming the low res version.
    3) Did you change your default resolution for full screen in your profile settings?

    Because Youtube is terrible with its resolution changes, I tend to use an app called "MegaTube" where you can set your resolution beforehand so that it will only load that resolution when you watch a video. You can then also download and save the video for offline or repeat viewing which can be very convenient.
     
    1 person likes this.
  4. GoodBytes

    GoodBytes Well-Known Member

    Joined:
    Jan 29, 2014
    Messages:
    1,071
    Likes Received:
    170
    Trophy Points:
    63
    To add:
    Did you try a different web browser? Which one are you using now?
     
  5. manoroid

    manoroid Member

    Joined:
    Jan 20, 2014
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    So right now I uninstalled all the way down to the standard Microsoft driver. The following photo shows its fine. But then installing the newest driver which currently came out with the Tuesday patches the other day runs with horrible pixilation as followed from my photos. NOt sure why this is happening. CaptureGood.PNG CaptureBad.PNG
     
  6. manoroid

    manoroid Member

    Joined:
    Jan 20, 2014
    Messages:
    45
    Likes Received:
    0
    Trophy Points:
    6
    Philltastic Ive made sure all your steps and nothing is fixing it.

    I'm using ie.

    Uninstalling the current driver probably won't show you the difference between the two photos. All I know is this current driver is making pictures and video pixilated.
     
  7. unruledboy

    unruledboy Active Member

    Joined:
    Jun 11, 2014
    Messages:
    284
    Likes Received:
    38
    Trophy Points:
    28
    Location:
    Sydney
    My Device:
    SPro3
    try another browser?
     
  8. GoodBytes

    GoodBytes Well-Known Member

    Joined:
    Jan 29, 2014
    Messages:
    1,071
    Likes Received:
    170
    Trophy Points:
    63
    The 2 pictures are identical. It's not Flash, it's not the web browser.
    The problem is Intel integrated graphics.

    There is a "feature" on the Intel integrated graphics which Intel calls: "Display Power Saving Technology"
    Based on my test, it saves nothing. The idea of the feature is to play with the contrast at a software level based on the content being displayed. The idea is that on dark content the screen increases the contrast, so you see better the content, and then, hopefully makes you decrease the brightness of the display, as you see things better or more easily. Cool idea in principal, sadly it's Intel, so its idiots that worked on it. Here is why I am saying this:
    1- It works on REVERSE. It dims the screen color (contrast) on dark scenes, making you increase the screen brightness even more, defeating the entire purpose of "power saving". It is more like "power consuming". This was NEVER fixed. It affects all Intel integrated graphics of this generation CPU.

    2- It is a software level adjustment. Adjusting colors properly at a software level, is VERY CPU taxing. So they are not doing it properly to minimize processing required (else it would defeat the purpose, of the idea that is great in principal). The result is however, a reduction in colors. If you open a picture editor and create a full screen gradient image (white to black, for example), you will see stepping, and not a smooth transition as you should.

    The better news is that it disables itself when you are plugged it.
    The good news, is that you can disable it completely! :)
    The bad news, is that, the system which turns this feature on or off, if you are plugged in or not, is ALSO broken, where it tends to forget that you are plugged in, and turns it on regardless. So, you definitively want this feature disabled.
    The bad news is that it ALSO tend to sometimes forget that you disabled it, and decides to enable it, and the only fix is restarting the system.

    Don't you love Intel?

    Yea. It sounds bad, but this is nothing new for Intel integrated graphics. Intel is most likely is outsourcing the development of it's drivers to India and/or China, which would explain the piss poor quality of it and the lack of any caring. And also, it would explain the lack of optimizations, like for example, if you have the Intel Control Panel menu items on the right-click menu, it takes more time to display than if you didn't. This shows that it does heavy CPU processing (probably loads stuff, not needed), at every right-click. And I can go on. You can disable it, but requires some registry tweaking 9basically remove Intel from the right-click menu)

    So how to fix it, somewhat (due to bugs where it forgets that you disabled it, sometimes)?
    -> Open the Intel HD Graphics Control Panel
    -> Go under Power, then on "On Battery", then disable: "Display Power Saving Technology", and click "Apply".
    -> Once done, go back, then go under Video, and make sure everything is set to "Application Settings". Then next to the "(<-)" (back) button, you'll see "Video", and a down pointing button, click on that.
    -> A menu should pop-up. Now go through each of them and again make sure that no colors are being adjusted, and everything is on "Application Settings". Of course, Apply when done
    -> Once all done, close, and restart your system.

    This should solve your problem. If it does not, they are more things we can do.
     
    Last edited: Jun 13, 2014
  9. olimjj

    olimjj Active Member

    Joined:
    Mar 27, 2013
    Messages:
    550
    Likes Received:
    113
    Trophy Points:
    43
    Location:
    Where no man has gone before.
    My Device:
    SPro3
    There is a newer Intel driver 3621. I have installed it, and to date I have noted no ill effects.
     
  10. GoodBytes

    GoodBytes Well-Known Member

    Joined:
    Jan 29, 2014
    Messages:
    1,071
    Likes Received:
    170
    Trophy Points:
    63
    I forgot to mention, sorry for this.
    The last firmware drivers has Display Power Saving, always on, and can't be turned off/ Even my Surface Tweak Tool which forces things via drivers settings is being ignored.
    I have installed the latest drivers as well. But the latest drivers still has the problem I have mentioned on my post.
     
  11. Davo22

    Davo22 New Member

    Joined:
    Jul 27, 2014
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    I was having the same issue.

    Only driver version.. 10.18.10.3262 would work without all the pixellation issues particularly in dark scenes.

    Newer driver version were horrible and rendered most of my movies unwatchable.

    Hope this helps.

    Cheers
     
  12. GoodBytes

    GoodBytes Well-Known Member

    Joined:
    Jan 29, 2014
    Messages:
    1,071
    Likes Received:
    170
    Trophy Points:
    63
    It's because Intel drivers doesn't display all colors, because 'dynamic power saving' is turned on.
    The fix is Surface Tweak Tool, which needs to be applied at every firmware or system hard update releases which contains Intel driver updates.

    Dynamic power saving feature is supposed to adjust display contrast and brightness at a software levels (which means, in order to not reduce performance and battery life too much, cuts out colors due to the quick job it does) to make dark scene brighter, so that you reduce yourself the screen brightness, which will save you battery life. Sadly, Intel proudly outsourced to India or China drivers, have the behavior on REVERSE. They never fixed it, and affects all Intel mobile GPUs. What some manufactures does is disable it by default. But in Microsoft case they leave it on.

    Surface Tweak Tool will go in the driver configurations, and fix this. If it doesn't work, then stay tune (like later today or tomorrow) for a new version of Surface Tweak Tool.
     

Share This Page

Search tags for this page
netflix is dark on surface 3
,
surface pro 2 intel graphic pixelated
,
surface pro 2 poor youtube video
,
surface pro 2 video playback pixelation
,
surface pro 3 hd movies black dark scenes
,

surface pro 3 netflix pixelated

,

surface pro 3 pixelation

,
surface pro3 video playback quality
,
youtube pixelated on windows 10
,
youtube pixillation problems