how to disable palm check on microsoft touchpad ??

Discussion in 'Microsoft Surface Pro' started by sossqq, Sep 8, 2013.

  1. sossqq

    sossqq New Member

    Joined:
    Sep 8, 2013
    Messages:
    15
    Likes Received:
    2
    Trophy Points:
    0
    My laptop usually run on that synaptic mouse driver so when I play games like wow I'd be able to turn it off.
    However, in surface pro its a built in microsoft driver and I cant find it anywhere.
    so basically when I am holding any key I wont be able to move my mouse cursor via mousepad.
    This palm feature is really helpful while we are typing but extremely annoying when we are playing games.
    Anyone have any suggestion?
    thanks.
     
    Last edited: Sep 8, 2013
  2. sossqq

    sossqq New Member

    Joined:
    Sep 8, 2013
    Messages:
    15
    Likes Received:
    2
    Trophy Points:
    0
    no one ? lol
    anyways good thing I have a premium account so I will contact microsoft and try to sort it out. :D
     
  3. lethal.industry

    lethal.industry New Member

    Joined:
    Jun 28, 2013
    Messages:
    26
    Likes Received:
    3
    Trophy Points:
    0
    having the same issue when playing games. if you can find a fix for it from the microsoft people pls post here! :)
     
  4. oion

    oion Well-Known Member

    Joined:
    Feb 15, 2013
    Messages:
    1,362
    Likes Received:
    265
    Trophy Points:
    83
    My Device:
    S2
    Not under mouse settings or the device manager? I usually disable my touchpad completely. Wait, you actually try to game in WoW using the touchpad and keyboard? That can't be efficient... Everyone I know who does that kind of gaming on a mobile device uses a proper external mouse, so the way you're using it could really be in the extreme minority, especially when players always recommend a mouse over touchpad/trackpad. No one would think to actually disable palm rejection for something like this because it's not an issue. So you shouldn't be surprised with a "no one?" after only a day. I take it the touchscreen doesn't register selection "clicks" (that would sure be preferable over the touchpad)?

    Outside of contacting MS, you may have better luck asking the XDA Developer forums, especially if it might require a registry or driver hack. Or just buy a cheap mobile mouse. :p
     
  5. sossqq

    sossqq New Member

    Joined:
    Sep 8, 2013
    Messages:
    15
    Likes Received:
    2
    Trophy Points:
    0
    I have been playing wow with my mouse pad for 2 yrs and I am really used to it by now. I take pro at work and I dont wanna use mouse there.I have contacted MS customer service and they will call me back later tonight. But, it looked like they have no idea either.
    I think you are right, this seems like a built in driver software so may need a little hack or some sort of app like "trackpad" to fix this.
    Well, to people who like playing game with mousepad thinking to buy pro ..beware :D
     
  6. sossqq

    sossqq New Member

    Joined:
    Sep 8, 2013
    Messages:
    15
    Likes Received:
    2
    Trophy Points:
    0
    has anyone tried logitech wireless touch K400?
    its around $35 and has a trackpad and more setting options.
     

Share This Page

Search tags for this page
cant disable palm rejection touchpad
,
disable surface pro touchpad
,
disable touchpad surface pro 3
,
how to completely disable palm check
,

how to disable palm check

,

how to disable palm check on the surface

,
microsoft surface pro disable touchpad when typing
,

ms surface palm check

,
synaptics palmcheck regedit
,
touchpad palm check