Issue with the graphics driver...

Discussion in 'Microsoft Surface Pro 2' started by VariableSpark, Dec 25, 2013.

  1. VariableSpark

    VariableSpark New Member

    Joined:
    Dec 25, 2013
    Messages:
    4
    Likes Received:
    2
    Trophy Points:
    0
    Hey all. New to the forum, so be gentle. ;)

    I have that screen flickering/adaptive brightness issue that a lot of people seem to get. I saw the topics about installing the Intel drivers to get the taskbar control app that allows you to properly turn off the "feature" and stop the screen flickering.

    Problem is....it won't let me install it, even when I wipe everything and reinstall Windows (through the recovery settings), to factory settings and don't update anything at all. When I try to update the drivers with the newest Intel drivers, it says that I already have the best driver installed for the device. And it doesn't give me the option to Rollback the driver. How is that even possible?

    I love my SP2, but this flickering is really driving me crazy.

    As of this posting, I have reinstalled Windows back to factory, and only installed the firmware drivers, nothing else. So....where do I go from here?


    Thanks.
     
  2. Zuldan

    Zuldan New Member

    Joined:
    Sep 29, 2013
    Messages:
    25
    Likes Received:
    5
    Trophy Points:
    3
    You have to uninstall the old generic driver first from device manager then you can install the new Intel driver.
     
  3. mxgaza33

    mxgaza33 New Member

    Joined:
    Dec 14, 2013
    Messages:
    5
    Likes Received:
    2
    Trophy Points:
    3
    You need to download the Win64_15338.zip from this link, not the .exe file.

    https://downloadcenter.intel.com/De..., 64-bit*&DownloadType= Drivers

    Once you've got that and its extracted you need to go into the device manager and right click on the graphics device found under "Display Adapters". Click "Update Driver Software" > "Browse my computer for driver software" > "Let me pick from a list" > "Have Disc.."

    Now you need to click "Browse" and point it to a file named "igdlh64.inf" which is found inside the folder you extracted earlier under the sub folder "Graphics".

    Once that's done hit next and let it install and the driver is installed!

    To stop the screen flickering, right click on the desktop and select the new option "Graphics properties" then "Power". Select "On Battery" and turn off both the "Display Power saving technology" and "Extend battery life for gaming" options. Done! Enjoy no screen flickering! :) I'd also turn off the adaptive brightness in the advanced power options if you haven't already, it's quite annoying!
     
    Last edited: Dec 25, 2013
    2 people like this.
  4. godson594

    godson594 Active Member

    Joined:
    Apr 5, 2013
    Messages:
    266
    Likes Received:
    33
    Trophy Points:
    28
    Location:
    Silicon Valley
    Its amazing to me this isn't fixed yet. !?

    This has been around since the sp1 i believe.
     
  5. VariableSpark

    VariableSpark New Member

    Joined:
    Dec 25, 2013
    Messages:
    4
    Likes Received:
    2
    Trophy Points:
    0
    Wow, do I feel stupid. :shocked:

    I was doing device manager->browse my computer and then just selecting the folder the driver was in, instead of 'let me pick->have disk'. The other instructions I had were more vague, and I didn't realise that I was doing it wrong. Thanks very much, everyone (especially mxgaza33), my Surface is perfect now!


    Cheers!
     
    2 people like this.

Share This Page

Search tags for this page
graffic driver issue
,
rhino 5 64 bit graphics problems microsoft surface
,
skytool graphics issue surface
,

surface 1graphics driver issues

,
surface book graphics driver issue
,

surface pro 2 graphics driver issue

,
surface pro 2 rhino 5 layout graphics issue
,

surface pro graphics driver bug

,

surface pro graphics driver problem

,
surfaceforums issue with the graphics driver