iTunes Launching Slowly After Anniversary

Discussion in 'Windows 10 on Surface Pro 3' started by Rich OReilly, Sep 1, 2016.

  1. Rich OReilly

    Rich OReilly New Member

    Joined:
    Dec 26, 2014
    Messages:
    25
    Likes Received:
    1
    Trophy Points:
    3
    After installing Anniversary, my ITunes is taking 10-15 min to open up.
    I tried uninstalling and reinstalling ITunes and I have the same issue.

    Is anybody else experiencing this or ideas how to fix?

    Thanks


    Sent from my iPad using Tapatalk
     
  2. bluegrass

    bluegrass Well-Known Member

    Joined:
    Nov 11, 2013
    Messages:
    1,300
    Likes Received:
    193
    Trophy Points:
    63
    Location:
    St. Louis, Mo
    My Device:
    SPro3
    I don't use iTunes but I thought I'd check since I have the Anniversary update installed. iTunes opened up almost immediately for me. I would suggest you look through the details in Task Manager to see if you can see if anything is eating up a bunch of your computer resources.
     
  3. Rich OReilly

    Rich OReilly New Member

    Joined:
    Dec 26, 2014
    Messages:
    25
    Likes Received:
    1
    Trophy Points:
    3
    Thanks, I have checked Task Manager and I dont see anything unusual. All other programs open fine. Only Itunes takes several attempts and takes up to 15 min.
     
  4. bluegrass

    bluegrass Well-Known Member

    Joined:
    Nov 11, 2013
    Messages:
    1,300
    Likes Received:
    193
    Trophy Points:
    63
    Location:
    St. Louis, Mo
    My Device:
    SPro3
    If it was me, I would uninstall iTunes and re-install it.
     
  5. Rich OReilly

    Rich OReilly New Member

    Joined:
    Dec 26, 2014
    Messages:
    25
    Likes Received:
    1
    Trophy Points:
    3
    I've uninstalled and reinstalled a few times. The last time I made sure I removed all remnants of Apple. Still takes forever to load. This is started happening after I installed Anniversary.



    Sent from my iPad using Tapatalk
     
  6. ScottyS

    ScottyS Active Member

    Joined:
    Apr 14, 2013
    Messages:
    672
    Likes Received:
    116
    Trophy Points:
    43
    Location:
    New York
    My Device:
    SPro3
    I've always felt iTunes loads slow compared to other apps (maybe because they don't use a splash screen), but even with Win10 AU it take only 4.8 seconds to load on my SP3.

    Something must be a problem with it on your system.
     
  7. JimHolland70

    JimHolland70 New Member

    Joined:
    Sep 12, 2016
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro3
    I'm having the same issue, but it's not 10-15 minutes, it's literally hours. I've uninstalled/reinstalled all Apple components and iTunes. Searched the web, can find nothing. I select to open it at 10 AM it'll literally pop open out of nowhere at 2 or 3 PM. Nothing in Task Manager indicates any major process running, though I can't force quit the iTunes process, even in Task Manager. I'm about to just give up and go back to Spotify.
     
  8. PhilC50

    PhilC50 New Member

    Joined:
    Sep 21, 2016
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Texas
    My Device:
    SPro2
    I have exactly the same issue and have tried all suggestions. Sometimes it will take hours as Jim stated.
    Weird thing, if I open the SDcard folder, iTunes launches immediately. Naturally I thought it was because I had Storage/Save Locations set to the SDcard. I changed them to This PC and rebooted. Now iTunes seems to open just fine. I'll make sure it's not a fluke over the next few days and report back.
     
  9. blasianEng

    blasianEng New Member

    Joined:
    Oct 17, 2016
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro3
    What a coincidence that you posted less than an hour ago. I saw this thread before and checked back if there were any solutions.

    This is a not a fluke! I opened the sd card folder and itunes opened right away. I am assuming since this is the surface forums most people are limited in storage and are using external storage for itunes so it's why only a small % of people (mostly surface owners that use iTunes) have this problem.

    Had to create an account. Hope microsoft fixes this.
     
  10. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,095
    Likes Received:
    1,724
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    I don't think Microsoft can fix a bug in Apple's Software....have you queried Apple support forums?
     
  11. blasianEng

    blasianEng New Member

    Joined:
    Oct 17, 2016
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro3
    How is it an Apple bug if it was working fine before the anniversary update? Even if it is an Apple issue, apple would never do anything about it. They didn't even make iTunes compatible with high dpi screens lol.
     
  12. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,095
    Likes Received:
    1,724
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    It is up to the ISV to make their software work with OS updates, that has been the case since commercially software became available.

    iTunes on Windows has a long tradition of being problematic....
     

Share This Page