January 14 patch updates and sleep issue

Discussion in 'Microsoft Surface Pro 2' started by eelpout, Jan 16, 2014.

  1. eelpout

    eelpout Member

    Joined:
    Dec 20, 2013
    Messages:
    78
    Likes Received:
    9
    Trophy Points:
    8
    FYI. I've had sleep issues since installing the Jan 14th patches on my SP2 (4300u).

    It has stopped "idle" sleeping, meaning after the set amount of time in the Power plan's sleep setting has passed, it won't sleep. It will go to sleep fine if I close the Type Cover, push the power button, run the battery down etc. Checking the event log confirms this.

    After trial and error I've determined that putting the device in Airport mode fixes the symptom and will allow it to "idle" sleep on its own. Not sure what was in the patches that triggered this issue with the network/radio infrastructure (as who knows where the problem really lies). What makes the "idle" timer different than the other triggers in this case I'm not sure. I believe it's much easier to preempt it in general.

    Just a heads up for people if they run into this.

    Edit: Looks like it doesn't have to be in Airport mode, turning off Wi-Fi alone will allow "System idle" sleep to function.
     
    Last edited: Jan 16, 2014
  2. MickeyLittle

    MickeyLittle Active Member

    Joined:
    Jun 18, 2012
    Messages:
    454
    Likes Received:
    51
    Trophy Points:
    28
    Location:
    Mississippi
    My Device:
    SPro3
    I wasn't happy with the feel of my device so I ran a refresh a little while ago.When I finished and checked for updates all the 1/14 updates were there for me to install again so you might want to do a refresh. It's not as time consuming as a restore and before it actually starts it will let you know what apps will need to be reinstalled before you do it.
     
  3. eelpout

    eelpout Member

    Joined:
    Dec 20, 2013
    Messages:
    78
    Likes Received:
    9
    Trophy Points:
    8
    I went through all the refresh/reset stuff with my last SP2 (which had a video bit-depth problem) don't want to start down that path with this replacement. ;)

    I did try rolling back all the patches from Tuesday and the sleep problem remained, so I've since reapplied them. I'll likely wait to see what MS does about it. I'm not the only one who has the issue so they'll fix it eventually. At least I have a workaround via turning off the network.

    Maybe I'll try uninstalling/removing all the Marvell AVASTAR radio drivers at some point and see how that goes, but I'm not convinced that's the issue, since there were no driver updates as part of the bundle from the 14th. I suppose it's possible a power policy on the driver got flipped or is now being misinterpreted and full removal of it and reinstall might help.
     
  4. eelpout

    eelpout Member

    Joined:
    Dec 20, 2013
    Messages:
    78
    Likes Received:
    9
    Trophy Points:
    8
    Update. Based on some threads I read of other wireless adapters, I tried turning off IPv6 in the network settings. Currently, idle sleep is functioning and I'll report back later if this is indeed a permanent solution.
     

Share This Page

Search tags for this page

surface problems after jan 14th update