New sp4 owner

Discussion in 'New Member Introduction & Site Assistance' started by keldec3, Feb 4, 2016.

  1. keldec3

    keldec3 New Member

    Joined:
    Feb 4, 2016
    Messages:
    3
    Likes Received:
    1
    Trophy Points:
    3
    My Device:
    SPro4
    Hello, new sp4(i5/128GB/4GB) owner. So far I'm mixed. I've had to restart a few times in order to get an app or to get the start menu to open. Anybody else have issues with the apps or start button showing you pressed them, but do nothing. I'm wondering if I have a defective unit? What do you guys suggest, should I take it back, or is this a know issue that will be fixed in an update?
     
  2. Eplak

    Eplak Member

    Joined:
    Feb 1, 2016
    Messages:
    49
    Likes Received:
    7
    Trophy Points:
    8
    Location:
    Norway
    My Device:
    SPro4
    Once you start up you Surface you have to install a bunch of updates. At least i had to do it. Most issues disappeared after installing all the updates. After you have updated, remember to search for more updates. Not all will come up at once.
     
  3. keldec3

    keldec3 New Member

    Joined:
    Feb 4, 2016
    Messages:
    3
    Likes Received:
    1
    Trophy Points:
    3
    My Device:
    SPro4
    Thanks, i did all the updates and it seems to be working a lot better now
     
  4. leeshor

    leeshor Well-Known Member

    Joined:
    Jun 19, 2012
    Messages:
    5,071
    Likes Received:
    877
    Trophy Points:
    113
    Location:
    Norcross, GA
    My Device:
    SPro4
    Great. Check for the updates until it says there are no more. Sometimes some updates generate dependencies on others and create more updates.

    And welcome to the forum.
     

Share This Page