New Type Cover 2 wont Type

Discussion in 'Microsoft Surface 2' started by Chad, Jun 12, 2016.

  1. Chad

    Chad New Member

    Jun 12, 2016
    Likes Received:
    Trophy Points:
    My Device:
    Let me get straight to the point.

    I recently ordered the Type cover 2 for my Surface 2 since the Touch cover that came with it originally, randomly died.

    I connected the Type cover and the backlight comes on but the I can't get it to actually type any characters. Weirdly enough I can adjust the type cover's backlight as well but still no out put on the actual screen.

    I tried everything I could. Refresh and reset won't work because its asking me for Recovery media which isn't on the tablet and I don't have a flash drive above 4 gobs so downloading that right now isn't feasible. The device management option doesn't work either as I can't find the keyboard option and even when I update the "other devices" list, it updates but nothing happens even when I restart the device.

    Does anyone know of an alternative solution to this issue????? I really need to use this keyboard tonight!!!!

Share This Page

Search tags for this page

new type cover 2 wont type