Solved No driver for MS ethernet adapter

Discussion in 'Microsoft Surface Pro 2' started by jrapdx, Sep 29, 2014.

  1. jrapdx

    jrapdx Member

    Joined:
    Jan 14, 2014
    Messages:
    259
    Likes Received:
    21
    Trophy Points:
    18
    Location:
    Oregon
    Just yesterday I bought a Microsoft ethernet adapter, the one MS sells specifically for SP1,2,3.

    So I attach it to a known good ethernet connection, and yes the cable works with another computer. However, the SP2 says no driver. I try to "update" the driver, but then it says no driver is to be found anywhere on the 'net. (Wifi does work...)

    Funny thing is that the ethernet adapter worked fine plugged into another computer's USB port. (Laptop running Linux, not even a current version, but it just worked.)

    What's up with the SP2 and the adapter? A quick look around the MS site didn't produce any answers.

    Appreciate any help with this little mystery!!
     
  2. jrapdx

    jrapdx Member

    Joined:
    Jan 14, 2014
    Messages:
    259
    Likes Received:
    21
    Trophy Points:
    18
    Location:
    Oregon
    Well, what did I know...

    Found the driver. In case anyone is looking for it, I downloaded it from here:
    http://www.microsoft.com/en-au/download/details.aspx?id=38826

    I installed manually, and where the install dialog asks about having a disk, click it and point it to the downloaded files. Select the "USB ndis6" driver, click Next, etc.

    It actually worked...
     
  3. leeshor

    leeshor Well-Known Member

    Joined:
    Jun 19, 2012
    Messages:
    5,071
    Likes Received:
    877
    Trophy Points:
    113
    Location:
    Norcross, GA
    My Device:
    SPro4
    Good deal. Marked solved.
     

Share This Page