No WiFi in Win10 Pro (1903) Windows Sandbox

Discussion in 'Surface Pro 6' started by wpcoe, May 25, 2019.

  1. wpcoe

    wpcoe Member

    Joined:
    Aug 6, 2017
    Messages:
    96
    Likes Received:
    8
    Trophy Points:
    8
    Location:
    Thailand
    My Device:
    SPro
    I (seemingly) successfully updated my Surface Pro 6 to v.1903 two days ago, and after some initial fumbles, now have Windows Sandbox enabled and it seems to open just fine. However, there is no WiFi access within Sandbox.

    Accessing Settings for Network & Internet, the list on the left is:

    Status
    Ethernet
    Dial-up
    VPN
    Airplane mode
    Date usage
    Proxy​

    WiFi appears no place in that window. Network status shows No Internet Access.

    I could be 100% off track, but I suspect it might have to do with "Hyper-V Extensible Virtual Switch" not being enabled:

    a.gif

    If I check the box in front of it and click OK, I get:

    b.gif

    ... and whether I click Yes or No, the box remains unchecked.

    If I click on Install I get:

    c.gif

    ... and don't know where to go after that.

    Help, please!
     
  2. iRob

    iRob New Member

    Joined:
    Jun 2, 2019
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    Other
    OK, if you Bridge connections between the Wifi Adapter and the vEthernet Hyper-V Virtual adapter you get a connection, extremely slow but at least something!

    Try it!

    iR
     
  3. wpcoe

    wpcoe Member

    Joined:
    Aug 6, 2017
    Messages:
    96
    Likes Received:
    8
    Trophy Points:
    8
    Location:
    Thailand
    My Device:
    SPro
    Thanks. I'll bookmark that for a future experiment. Problem is, now I can't even launch Sandbox:
     
  4. iRob

    iRob New Member

    Joined:
    Jun 2, 2019
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    Other
    I finally figured out.
    In Norton Firewall I put the Windows Sandbox Ethernet adapter MAC address under trusted device and now Windows Sandbox has connection
     

Share This Page