On screen keyboard problem

Discussion in 'Microsoft Surface Pro' started by Arizona Willie, Mar 19, 2013.

  1. Arizona Willie

    Arizona Willie Active Member

    Joined:
    Feb 24, 2013
    Messages:
    685
    Likes Received:
    51
    Trophy Points:
    28
    Location:
    Mesa, Arizona
    The other day I was playing around with the Paint program ( the Windows freebie ) and went to save a sketch and could NOT get the on screen keyboard to pop up:(

    It seems to work in some programs but not others. Came up ok, although slowly, in Word 2013.

    Anyone know how to fix this?
     
  2. J515OP

    J515OP Super Moderator

    Joined:
    Jun 19, 2012
    Messages:
    2,177
    Likes Received:
    262
    Trophy Points:
    0
    Location:
    Northern CA
    My Device:
    RT
    Did you try attaching/detaching the cover keyboard to see if that helped?
     
  3. bosamar

    bosamar Well-Known Member

    Joined:
    Nov 10, 2012
    Messages:
    1,453
    Likes Received:
    78
    Trophy Points:
    48
    My Device:
    RT
    The 'Paint' program opens on the Desktop therefore the keyboard will not auto-pop. You have to select it from the taskbar.
     
  4. Arizona Willie

    Arizona Willie Active Member

    Joined:
    Feb 24, 2013
    Messages:
    685
    Likes Received:
    51
    Trophy Points:
    28
    Location:
    Mesa, Arizona
    If I had the keyboard I wouldn't have been trying to use the onscreen keyboard :)

    I could have gone to get it, but that defeats the idea of being able to carry ONLY the tablet.
    If we have to carry a mouse, and a keyboard and the tablet ... might as well have the full laptop.


     
  5. Arizona Willie

    Arizona Willie Active Member

    Joined:
    Feb 24, 2013
    Messages:
    685
    Likes Received:
    51
    Trophy Points:
    28
    Location:
    Mesa, Arizona
    There IS no keyboard icon on my Taskbar.

     
  6. J515OP

    J515OP Super Moderator

    Joined:
    Jun 19, 2012
    Messages:
    2,177
    Likes Received:
    262
    Trophy Points:
    0
    Location:
    Northern CA
    My Device:
    RT
    I realize that ;) but there is a known issue with the Surface Pro. If you detach the keyboard while it is asleep then it still thinks it is attached. The only way to clear the situation might be to reattach and then detach the keyboard properly. Once you have the ability to call up the onscreen keyboard you can detach the physical keyboard and then use just as you described.

    The proposed solution isn't about using the cover keyboard instead of the onscreen but about clearing the issue of the onscreen keyboard to get it working again :) You might also need to reboot.
     
  7. tonyz3

    tonyz3 New Member

    Joined:
    Jan 28, 2013
    Messages:
    729
    Likes Received:
    118
    Trophy Points:
    0
    Also to get the keyboard icon on the taskbar for the Desk top. RT click on the taskbar and add it. under toolbars
     
  8. Arizona Willie

    Arizona Willie Active Member

    Joined:
    Feb 24, 2013
    Messages:
    685
    Likes Received:
    51
    Trophy Points:
    28
    Location:
    Mesa, Arizona
    Oh, yeah, I'm aware of the need to attach / remove the keyboard only while the computer is on. I've made it a point to do that ever since I found out about it.
    I'm fairly sure that isn't the problem.

    I see there is a tip on adding the keyboard to the taskbar and I'm going to do that and see how that works.

    -------------
    OK, just tested it. Removed keyboard while Surface was turned on at the Start screen.
    Went to the desktop and ran Paint.
    Pulled a pic up and tried to do a Save As and clicked in the Name box but the keyboard does not auto-pop.
    I can tap the keyboard icon and bring it up --- that works.

    But the question remains --- WHY doesn't the keyboard pop up automagically when you click in a text box?
    Is there a setting to chose this behavior somewhere?

    If I click with the Mouse or tap with my finger / pen in a text box ... a keyboard should pop up automatically.

     
    Last edited: Mar 20, 2013
  9. ArnoldC

    ArnoldC New Member

    Joined:
    Nov 26, 2012
    Messages:
    1,537
    Likes Received:
    110
    Trophy Points:
    0
    Location:
    Makati, Philippines
    You're in the Desktop using legacy apps. That will not bring the on screen keyboard automatically.

    There's a CNET article about legacy apps need to go touch. You may want to look into it.
    Sent from my Windows Phone 8S by HTC using Board Express
     
    1 person likes this.
  10. J515OP

    J515OP Super Moderator

    Joined:
    Jun 19, 2012
    Messages:
    2,177
    Likes Received:
    262
    Trophy Points:
    0
    Location:
    Northern CA
    My Device:
    RT
    Glad you got it working :) This is the known and expected behavior of the keyboard in desktop. It is a design decision by MS. In Modern UI text field = auto-keyboard popup but in desktop you must always manually pop the keyboard up by using the icon in the lower right. So far there is no way to change this behavior.

    JP
     
    1 person likes this.
  11. vinumsv

    vinumsv New Member

    Joined:
    Mar 20, 2013
    Messages:
    84
    Likes Received:
    10
    Trophy Points:
    0
    Location:
    India
    Right Click Empty Part your Taskbar then Toolbars > Tablet PC Input

    Now you should see keyboard icon
     
  12. Arizona Willie

    Arizona Willie Active Member

    Joined:
    Feb 24, 2013
    Messages:
    685
    Likes Received:
    51
    Trophy Points:
    28
    Location:
    Mesa, Arizona
    Yeah, didn't think about Paint being a legacy app.
    Just expected they would have updated all the components of Windows when they moved up to Windows 8.
     

Share This Page

Search tags for this page
microsoft surface pro keyboard auto pop up
,
surface keyboard problem
,
surface on screen keyboard prob
,

surface pro 2 keyboard problems

,
surface pro 3 on screen keyboard issues
,
surface pro keyboard issues
,
surface pro keyboard problem
,

surface pro keyboard problems

,
surface pro on screen keyboard
,
surface pro screen keyboard problem