Post Your SP3 WiFi/Internet Issues Here

Discussion in 'Microsoft Surface Pro 3' started by leeshor, Aug 10, 2014.

  1. thunderbolt71

    thunderbolt71 New Member

    Joined:
    Nov 25, 2015
    Messages:
    3
    Likes Received:
    1
    Trophy Points:
    3
    My Device:
    SPro3
    Hi Guy,
    believe it or not the first try was MS Help. They recommended downloading updates. :)
    I do go to the garage but there are people who can usually fix. You referred to "Multiple times a solution is given here".
    Fine. Multiple times different solutions.

    For example "remove driver and reinstall" - If I remove the driver Windows automatically reinstalls the latest one.
    For another example: "reload old driver" - On MS download sites one can only access the latest versions. I found an archive of old drivers, tried to install and the system does not let me do so stating that I have newer version on the disk.

    I am honestly not an IT specialist, just would like to use my stuff for what I bought it.
    I also believe in the voice of the customers and thought that at forums like this it could be made heard. Windows 10 is far from ready. If You just can tell me how to reinstall 8.1, that may be fine. That at least worked with the wifi.

    Thanks for trying anyway.
     
  2. Silver0066

    Silver0066 Member

    Joined:
    Dec 2, 2014
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    6
  3. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,326
    Likes Received:
    1,755
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    Gerke likes this.
  4. Fabian

    Fabian New Member

    Joined:
    Jan 27, 2016
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro3
    I was complaining to Netgear that their latest FW update of my router broke the wifi. After the update I got only 20/10 Mbps or less, instead of the 70/10 that I had before the update. I even reset the router to factory defaults, but to no use...

    Now it turns out that it is my SP3, i7, 512GB, that misbehaves with the 2.4 GHz wifi when a USB 3 stick is inserted. With a USB stick inserted I get seriously degraded wifi performance, a little different depending on which stick I put in, but always significantly degraded performance and often simply no internet connection at all! And these are not the cheapest USB sticks, I only use Corsair sticks.

    Obviously there is some bad engineering here, and no way around it. My Sp3 pro experience is getting increasingly painful the more I use the SP3. I am getting sooo tired of this expensive piece of junk...
     
  5. Imperator145

    Imperator145 New Member

    Joined:
    Feb 21, 2016
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro3
    Hi,
    I am new in this Forum. and sorry for my bad english.

    But now i have Internet-Problems.

    What can i do?
    No Internet-Connection is available.

    I think it's the Adapter.
     
  6. Gerke

    Gerke Member

    Joined:
    Aug 6, 2013
    Messages:
    89
    Likes Received:
    10
    Trophy Points:
    8
    Location:
    Veenendaal, The Netherlands
    My Device:
    SPro3
    Did you read the posts in this thread? Try the last 5 pages ;)
     
  7. sharpuser

    sharpuser Super Moderator Staff Member

    Joined:
    Aug 20, 2013
    Messages:
    3,182
    Likes Received:
    1,077
    Trophy Points:
    113
    Location:
    Pacific Northwest & China
    My Device:
    Surface Book
  8. pdogg93

    pdogg93 New Member

    Joined:
    Jun 6, 2016
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro3
    Hi all, recently bought a surface 3 pro on craigslist for a very good deal. Looked to be in mint condition, everything boots up, it holds a charge and there do not appear to be any issues... other than the network adapter.

    I have tried honestly everything i can think of to get this thing going, but alas, i cannot for the life of me get 'network adapters' to show up in the device manager tree. I have reset the computer 3 times (windows 8.1), I have tried all of microsoft's recommended solutions, reloaded network drivers new and old. Nothing makes the tree pop up.

    I'm guessing the marvell chip is broken, which is just baffling. I can't get bluetooth on it either, which is weird because the seller included a bluetooth mouse with it. Obviously it is out of warranty. Any ideas what i could do to fix it?

    Would a usb wifi/bluetooth stick be my only option?

    thanks a lot in advance.
     
  9. Joe S.

    Joe S. New Member

    Joined:
    Jan 30, 2015
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1

    Been there, done that. I bought mine new and after a couple months same thing. Since I was under warranty, I worked with MS tech support and we tried a few things and then they gave me an RMA and I exchanged it at a local MS Store. Been good since. Not good for U though.

    There's a USB connector hub out there that you plug in and it's got 3 USB 3.0' s and has upto a 1Gig connection availability. I use this occasionally when transferring large files from the SP3 to my NAS. Got it on Amazon pretty cheap (~$20). Here's the link...

    Amazon.com: Unitek 3 Ports USB 3.0 Hub with RJ45 10/100/1000 Gigabit Ethernet Adapter Converter LAN Connecter for Apple Macbook Pro Air, Imac, Mac, Chromebook Pixel, Microsoft Surface Pro, Lenovo Yoga, Laptop, Ultrabook: Computers & Accessories

    If the link don't work, the name is "Unitek 3 Ports USB 3.0 Hub with RJ45 10/100/1000 Gigabit Ethernet Adapter Converter LAN Connector".

    Good Luck,

    joe
     
  10. Pedrom

    Pedrom Member

    Joined:
    Jan 7, 2015
    Messages:
    39
    Likes Received:
    7
    Trophy Points:
    8
    Location:
    UK
    My Device:
    SPro3
    Have you tried getting in contact with the seller? I know it's not their responsibility any more - but it doesn't hurt to ask. He/she is the only one likely to know if there's something actually broken, or just a setting that needs changing
     
  11. pdogg93

    pdogg93 New Member

    Joined:
    Jun 6, 2016
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro3
    Thanks for the link and advice. I'll see whether there's anything I can do at the MS store. Very disappointed. I've owned so many laptops in my time and I've never seen a component failure like this. Oh well, live and learn.
     
  12. pdogg93

    pdogg93 New Member

    Joined:
    Jun 6, 2016
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro3
    I've changed every setting imaginable, and reset it multiple times. The hardware simply isn't popping up in the device manager tree as if it's not even there physically.
     

Share This Page

Search tags for this page
sp3 wifi drivers 10074
,

sp3 wifi issues

,
sp3 wifi issues youtube
,
surface pro 3 wifi connects at lower spee when switching networks
,
surface pro 5g connection issues
,
surface pro exclamation on wifi
,
surface wifi problem after windows update feb 2015
,

wifi issues sp4

,

wifi slower on surface pro 3 than other devices

,
windows 10 wifi issues sp3