Solved powercfg stopped having sleepstudy option

Discussion in 'Microsoft Surface Pro 3' started by Joon, Oct 24, 2014.

  1. Joon

    Joon New Member

    Joined:
    Oct 24, 2014
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    I believe after an update (I'm not sure which one), my Surface Pro 3's powercfg stopped having the sleepstudy option:

    PS C:\WINDOWS\system32> powercfg sleepstudy
    The Power Efficiency Diagnostic library (energy.dll) could not be loaded.

    I do have energy.dll in C:\Windows\system32. Is there any way to fix this?
     
  2. Joon

    Joon New Member

    Joined:
    Oct 24, 2014
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    It suddenly came back, after I open an administrative cmd.exe. I'm happy it is back but I have no idea why :)
     
  3. GreyFox7

    GreyFox7 Super Moderator Staff Member

    Joined:
    Jul 27, 2014
    Messages:
    6,341
    Likes Received:
    1,279
    Trophy Points:
    113
    The Psychiatrist is in. 5 minutes 25c :D
     
  4. ctitanic

    ctitanic Well-Known Member

    Joined:
    Nov 3, 2012
    Messages:
    2,194
    Likes Received:
    577
    Trophy Points:
    113
    Location:
    Hollywood, FL
    My Device:
    SPro3
    Those options need to be run as administrator.
     
  5. Joon

    Joon New Member

    Joined:
    Oct 24, 2014
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    I know - I have been running it in an administrative Powershell session. The options were gone for a while then it came back. Since I tried multiple times with new sessions, I don't think it was caused by me mistakenly running normal posh sessions. Anyway, the options were back when I invoked it in an administrative cmd session.
     

Share This Page

Search tags for this page

powercfg energy dll download

,

powercfg sleepstudy you do not have permission