Solved Powered USB Hub for SP4 with Dock and no Jitters?

Discussion in 'Microsoft Surface Pro 4' started by torwalker, Nov 21, 2016.

  1. torwalker

    torwalker New Member

    Joined:
    Nov 21, 2016
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro4
    Hi I have a big problem with a jittery cursor when I use my SP4 with the type cover touchpad. I use the SP4 with the Surface Dock running the latest firmware. I need more USB connections than provided by the Dock and so I am trying a powered USB hub (this one: https://www.amazon.co.uk/gp/product/B0177AF0KK/ref=oh_aui_detailpage_o02_s00?ie=UTF8&psc=1 ). I also bought a 10w 5v 2A power supply to use with the hub. This all works but has resulted in a jittery cursor with the touchpad. It is fine when the hub is removed but comes back if the hub is reconnected either to the dock or directly to the SP4.
    Does anyone know a powered USB hub that works for them? It needs to be powered because I need to connect external hard drives.
    Thanks in advance!
     
  2. Metalman

    Metalman Member

    Joined:
    Apr 13, 2014
    Messages:
    47
    Likes Received:
    6
    Trophy Points:
    8
    torwalker likes this.
  3. torwalker

    torwalker New Member

    Joined:
    Nov 21, 2016
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro4
    Hi Metalman
    Thanks for replying. Can't get the exact same hub (not available) but I am trying a very similar one. Will post how I get on. These erratic jittery touchpads drive me crazy. Hope I've found a solution!
    Thanks again.
     
  4. Metalman

    Metalman Member

    Joined:
    Apr 13, 2014
    Messages:
    47
    Likes Received:
    6
    Trophy Points:
    8
    Sorry, I don't see that it was not available.
    Hope you find one that works
     
  5. torwalker

    torwalker New Member

    Joined:
    Nov 21, 2016
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro4
    Ok good news - received HooToo model number HT-UH010 today - USB 3.0 7-port hub with 2 charging ports. This is working fine! The answer may well lie in the 12V 5A 60W power supply which turns out to be compatible with the surface dock, whereas what I used before (5V) wasn't. So my advice - if you need an extra powered usb hub make sure it is 12v and has a high wattage rating. At least it worked for me and thanks to Metalman for pointing me in the right direction.
     

Share This Page