Problem with resolution in desktop mode

Discussion in 'Microsoft Surface Pro 2' started by padders, Oct 23, 2013.

  1. padders

    padders New Member

    Joined:
    Oct 23, 2013
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    0
    Just bought a Surface Pro 2 - my first use with device.

    I appear to have some problem with the resolution in desktop mode; the resolution looks "right" in tablet mode; but going into desktop and using the browser (I installed chrome) and other apps - I have much lower resolution.

    Looking at the Screen Resolution (Appearance & Personalisation -> Display -> Screen Resolution) says 1920 x 1080 as expect. But I installed something called Pixel Ruler and that is showing a horizontal resolution of about 1280 pixels as far as I can tell. I can tell that looking at websites on the surface compared to my monitor (same resolution) that something is very different.

    Any ideas? As it is; this device is unusable; so I hope there is a fix.
     
  2. mitchellvii

    mitchellvii Well-Known Member

    Joined:
    Mar 30, 2013
    Messages:
    2,483
    Likes Received:
    559
    Trophy Points:
    113
    Location:
    Charlotte, NC
    My Device:
    SPro3
    What is your magnification set to? If it is set to stock 150% there is our problem - your extended monitor is also 150%. However the tradeoff is if you set it to 100% things will look great on your extended monitor and tiny on your Surface Pro. And no you cannot set magnification for each monitor individually.

    The best trade-off is to set Surface Pro magnification to 125%. Readable on SP and not too big on external monitor.

    The other option if you must have 100% magnification at 1920 x 1080 on your extended monitor is to set the resolution on your SP to 1600 x 900 and 100% magnification. This gives you the same sizing on the SP as 1920 x 1080 at 125% and the screen image looks pretty much the same quality but you get full 1920 x 1080 x 100% on your extended monitor.

    ** To access magnification settings just do Control Panel > Display. I suggest you just stick with the same % for both monitors. It gives you the impression you can set each separately but that really doesn't work well. As usual, instead of just allowing us to set magnification for each monitor separately as we asked, MS gave us a complex solution no one wanted.
     
    Last edited: Oct 23, 2013
    1 person likes this.
  3. kayzee

    kayzee Well-Known Member

    Joined:
    May 31, 2013
    Messages:
    2,082
    Likes Received:
    228
    Trophy Points:
    63
    Location:
    Essex, UK
    My Device:
    SPro
    Or exclusively run Modern UI on your Surface and you wont have this problem at all :) (although obviously it's not ideal if you don't want to run it that way)
     
  4. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,095
    Likes Received:
    1,724
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    I use the equivalent of 125% on my 24" Monitor and 150% on my SP2, works well enough.
     
  5. HoHo

    HoHo New Member

    Joined:
    Feb 12, 2013
    Messages:
    15
    Likes Received:
    2
    Trophy Points:
    0
    Location:
    Tracy, California, USA
    The default display setting is set to 150% to make items bigger for easier reading in a small screen. To update back to 100%, go to Control panel, choose Display, then under Change the Size of All Items. Change to "Smaller" which is 100%. This will give you true 1920 X 1080 resolution. You can set this setting independently on the SP2 (10" HD screen) and any external display (ie. 27" HD screen).
     
    1 person likes this.
  6. Sher the Love

    Sher the Love Member

    Joined:
    Oct 16, 2013
    Messages:
    121
    Likes Received:
    11
    Trophy Points:
    18
    If you're talking about the display looking fuzzy, right click the executable file> properties> compatibility> and check the part about the DPI scaling.

    You'll go from this:

    Capture2.PNG


    To this:

    Capture.PNG
     
    1 person likes this.
  7. Elusive

    Elusive New Member

    Joined:
    Oct 24, 2013
    Messages:
    12
    Likes Received:
    0
    Trophy Points:
    0
    Chrome supports high-DPI scaling, but it's not on by default. This can result in it being fuzzy, and also touch input won't work properly.

    To resolve this, open Chrome and type in the location bar:

    chrome://flags/#high-dpi-support

    Change the setting from 'Default' to 'On'. It's not perfect, but it does resolve issues when browsing the web, sharpness, and touch input.

    Hope that helps.
     

Share This Page

Search tags for this page
best screen resolution for surface pro 2
,
change resolution desktop surface pro
,
ideal desktop resolution of surface 2
,
resolution of differentdesktop apps on microsoft surface
,
surface 2 desktop mode
,
surface desktop resolution
,
surface pro 2 default resolution
,
surface pro 2 monitor resolution
,

surface pro 2 screen resolution

,
surface pro desktop resolution