S3; Poor performance with web applications.

Discussion in 'Surface 3 (Atom)' started by simrj002, May 18, 2015.

  1. simrj002

    simrj002 New Member

    Joined:
    May 18, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    Surface 3 (Atom)
    Hi,

    Just picked up the 4gb/128 S3 model and for all intents and purposes I am really happy.

    One thing I had hoped to do on the unit that I'm struggling with is using it for editing and collaborating in google docs. Unfortunately the performance is far too slow to be usable. I have noticed that web performance in all browsers is pretty poor(but usable) but as soon as I try to use a cloud application it is just too frustrating.

    Symptoms persist regardless of router. System is up to date, clean and there is plenty of memory available.

    Is the Atom chip just not cut out foe this type of work? All my desktop programs run great.
     
  2. leeshor

    leeshor Well-Known Member

    Joined:
    Jun 19, 2012
    Messages:
    5,071
    Likes Received:
    877
    Trophy Points:
    113
    Location:
    Norcross, GA
    My Device:
    SPro4
    Welcome to the forum

    You didn't mention what browser?
     
  3. simrj002

    simrj002 New Member

    Joined:
    May 18, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    Surface 3 (Atom)
    I have tried the most common browsers. IE desktop and metro, Firefox, Chrome and Opera. IE metro got the best performance but it was still unusable.
     
  4. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,105
    Likes Received:
    1,724
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    Its Google's Web APIs....
     
  5. simrj002

    simrj002 New Member

    Joined:
    May 18, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    Surface 3 (Atom)
    That's a good theory but then shouldn't I experience the same issue on an SP3, which I don't. Also I get similar performance slumps in office products for example when editing a word document in the desktop application when the document is sitting in one drive. If I drag the document to the desktop performance is great.
     
  6. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,105
    Likes Received:
    1,724
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    What are you using for Antivirus? I've seen Google services struggle with new SoC implementation previously but if you're experiencing with Office as well its sounds like something in the network stack or network.
     
  7. simrj002

    simrj002 New Member

    Joined:
    May 18, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    Surface 3 (Atom)
    I'm using bit defender. I have to admit I haven't tried it with antivirus off. I installed the antivirus before I tested these things
     
  8. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,105
    Likes Received:
    1,724
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    I've seen issues with Bit Defender, there is a thread about it on the SP3 forum....
     
  9. InspectHerGadget

    InspectHerGadget Active Member

    Joined:
    Sep 1, 2014
    Messages:
    420
    Likes Received:
    58
    Trophy Points:
    28
    I agree it would be worth removing the antivirus. It could be on an Atom processor you might be better just removing all security products and just use the built in Windows Defender. I would check your internet speed also when this problem happens.
     

Share This Page