Solved Screen Rotation switch inactive

Discussion in 'Windows 10 Forum' started by Maciek, Jul 31, 2015.

  1. Maciek

    Maciek New Member

    Joined:
    Oct 26, 2014
    Messages:
    22
    Likes Received:
    1
    Trophy Points:
    3
    So, my "Lock Rotation" switch is grayed out. When I turn my SP3 into the portrait mode it switches to the tablet mode, but rotation still won't work.

    This bug was already reported in previous builds http://www.surfaceforums.net/threads/auto-rotation-bug-win-10.12227/

    Any news on this? Or is it just me?

    I know I could try the registry, but why should I? It should just work, no?
     
  2. majorgearhead

    majorgearhead Member

    Joined:
    Apr 12, 2015
    Messages:
    53
    Likes Received:
    5
    Trophy Points:
    8
    Location:
    West By God Virginia
    My Device:
    SPro3
    I found initially on Windows 10, screen rotation is locked. I had to put the SP3 into Tablet Mode and then swipe from right to bring up the notification panel. Then the greyed out option was clickable again, and I tapped it to disable the lock. Now it rotates as normal.

    Kind of an odd choice for MS to do by default. I do notice that in Windows 8.1 it is the same thing until you try and rotate without the keyboard, then the option is selectable again.
     
  3. hughlle

    hughlle Super Moderator Staff Member

    Joined:
    Jul 7, 2014
    Messages:
    2,700
    Likes Received:
    422
    Trophy Points:
    83
    Hmnm. Didn't experience this with either of my surfaces.

    For reference though, auto rotate will be disabled if you have the keyboard attached, are docked, or are running more than one monitor.
     
  4. Maciek

    Maciek New Member

    Joined:
    Oct 26, 2014
    Messages:
    22
    Likes Received:
    1
    Trophy Points:
    3
    I did this and you were right. It worked, but it was not the case in w8.1, not in my case anyway.
     
    vap0rtranz likes this.
  5. vap0rtranz

    vap0rtranz New Member

    Joined:
    Nov 25, 2014
    Messages:
    13
    Likes Received:
    1
    Trophy Points:
    3
    Ditto for my Surface Pro. Also, if you select "Don't ask me" then it should autoswitch between modes. When I plug my Touch keyboard, my Surface switches to Desktop; and unplugging the keyboard switches back to Tablet.
     

Share This Page

Search tags for this page
lock rotation greyed out windows 10
,
lock rotation of the display grayed out
,
lock rotation of this display grayed out
,

lock rotation of this display greyed out

,
rotation lock greyed out
,
rotation lock greyed out surface pro
,

rotation lock greyed out windows 10

,
windows 10 lock rotation grayed out
,
windows 10 rotation lock grayed out
,
windows 10 rotation lock greyed out