SD card woes... and I've tried all the fixes I can find!

Discussion in 'Microsoft Surface Pro 3' started by richardfrank, Nov 3, 2015.

  1. richardfrank

    richardfrank New Member

    Joined:
    May 8, 2015
    Messages:
    1
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro3
    Really hope someone can suggest something new?

    I have a Surface Pro 3 i5 running Win10 - all up to date.

    I recently purchased a Lexar microSDxc 128GB card (a very fast one 633x) from amazon.co.uk

    Popping it into the machine it appeared as I'd have expected and then a minute or two later just simply disappeared (not just from Explorer, but from the Disk Management interface - and from the Device Manager too).

    I've so far tried the following (as recommended in various posts across the web):
    • A different card (I have a 256mb card from a long time ago)
    • Uninstalling/deleting the existing driver and allowing Win to install a generic one (which I've done and it's still there) - as per the well-known reddit post
    • Part removing the card from the socket
    • Taking the card and formatting on my desktop to NTFS and doing it with a full (not quick) format
    ...but nothing helps.

    Every time I put it in, I get the same behaviour - all fine for a minute or two, then simply disappears.

    If it's a dud Pro 3 I'm a bit stuffed since it's out of warranty (I've never had need to use that slot before) - but there do seem to be an awful lot of people out there with something like this problem - anything I'm missing?

    I'd really appreciate any insights or suggestions.
     
  2. Sir Guy Mann

    Sir Guy Mann New Member

    Joined:
    Dec 23, 2015
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro3
    First, format it to FAT32 using a formatter designed for SD cards. Then fill it with data from your computer, anything, just fill it.
    Put in your device and it should remain visible. Delete the data and use.
     
  3. Gerke

    Gerke Member

    Joined:
    Aug 6, 2013
    Messages:
    88
    Likes Received:
    10
    Trophy Points:
    8
    Location:
    Veenendaal, The Netherlands
    My Device:
    SPro3
    I have had 2 lexar microsdxc. Both with the same problems. Never again Lexar, now I've switched to Sandisk, never had any problems again
     
  4. next_milenium

    next_milenium Member

    Joined:
    Feb 4, 2015
    Messages:
    95
    Likes Received:
    11
    Trophy Points:
    8
    I have the same issue with Samsung 64GB. It's been better with Win10 but but it still happens from time to time.
     

Share This Page