Solved "Sleep" Disappeared from my Surface 4 Pro

Discussion in 'Microsoft Surface Pro 4' started by momen888, Jul 19, 2018.

  1. momen888

    momen888 New Member

    Joined:
    Jul 19, 2018
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro4
    After the windows update on early June I noticed that there is no more Sleep option on Surface 4 Pro. The physical button up doesn't do anything anymore.
    I tried contacting Microsoft but no answer but the annoying virtual assistant.
    I tried (powercfg /a) in command prompt and got the results attached below. I did a check with the Surface Diagnostic Toolkit from Microsoft's website and it told me that "Modern Standby" was disabled.
    What to do to get that option back? Now I have to shutdown the device after every use if not at the office. This defeats the purpose of having a surface device !! Capture.JPG
     
    Last edited: Jul 19, 2018
  2. sharpuser

    sharpuser Super Moderator Staff Member

    Joined:
    Aug 20, 2013
    Messages:
    3,455
    Likes Received:
    1,125
    Trophy Points:
    113
    Location:
    Eastern USA & China
    My Device:
    Surface Book
    Hi, @momen888,

    Perhaps you need to do a Windows Reset ('Keep my files' option). Sleep state has not been discontinued.

    upload_2018-7-19_8-46-43.png
     
  3. momen888

    momen888 New Member

    Joined:
    Jul 19, 2018
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro4
    Well, I'm trying to avoid resetting as much as possible. Last time I reset another device and things got much worse. It was working fine, the sleep just disappeared after an update. Why can't fixing things be easy as messing them up?!
    I am looking for another solution if possible. If not, probably I have to reset it but with it goes any privilege I thought a Microsoft device would have. It just proves that it is as messed up as my old Samsung!!
     
  4. sharpuser

    sharpuser Super Moderator Staff Member

    Joined:
    Aug 20, 2013
    Messages:
    3,455
    Likes Received:
    1,125
    Trophy Points:
    113
    Location:
    Eastern USA & China
    My Device:
    Surface Book
    Have you tried a cold boot?
     
  5. momen888

    momen888 New Member

    Joined:
    Jul 19, 2018
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro4
    Yes I did. Actually, the first time I noticed the option was missing was when it finished updating, I put it in my bag and forgot about it for the weekend. Later I discovered that the battery had run out and it wasn't sleeping. The sleep option just wasn't there anymore. I tried hard shutdown even draining it again out of battery but no use.
    There is something that was updated and disabled Modern Standby.
    I even reinstalled the drivers from Microsoft's webpage.
     
  6. sharpuser

    sharpuser Super Moderator Staff Member

    Joined:
    Aug 20, 2013
    Messages:
    3,455
    Likes Received:
    1,125
    Trophy Points:
    113
    Location:
    Eastern USA & China
    My Device:
    Surface Book
    You might consider becoming a Windows Insider, Fast Ring. A side benefit, besides cool new features, is that your Windows 10 is freshly installed with no loss of files every week or two, as you desire.
     
    momen888 likes this.
  7. momen888

    momen888 New Member

    Joined:
    Jul 19, 2018
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro4
    I just did so, and it worked :D
    My surface now is back to normal...
    Thanks for the advice :)
     
  8. sharpuser

    sharpuser Super Moderator Staff Member

    Joined:
    Aug 20, 2013
    Messages:
    3,455
    Likes Received:
    1,125
    Trophy Points:
    113
    Location:
    Eastern USA & China
    My Device:
    Surface Book
    Excellent! There are firmware and software combinations in these new builds that seem to have solved your issues

    Marking Solved.
     
    momen888 likes this.

Share This Page