solution - achieving 1% drain on battery now!!!

Discussion in 'Microsoft Surface Pro 4' started by stevae, Jan 22, 2016.

  1. stevae

    stevae New Member

    Joined:
    Jan 16, 2016
    Messages:
    9
    Likes Received:
    1
    Trophy Points:
    3
    My Device:
    SPro4
    ok, so after putting my surface pro 4 into safe mode, and loading the new intel drivers, adding the script from neowin, to allow max power management of the processor, adding hyerV back through the "adding and removing windows features" feature, i am finally getting what we all should have gotten all along.
    i unplugged my machine last night (early this morning) at 12:14am, and put it to sleep by putting the type cover up. then i checked it a few hours later and it was still on 100%. so i went to bed, and didn't look at it again until 12:43 pm today, and it was at 87%. that's 12.5 hours of sleep, losing 13%. so juuuuuust barely over 1% per hour. also, i put my max pros. power at 94% on battery, and 89% plugged in. this keeps the fans from kicking on almost at all on battery, and only very rarely while plugged in. yet, the tablet runs everything extremely quickly and smoothly. everything seems to be running optimally. hope this helps.
     
    Spider likes this.
  2. kundas1

    kundas1 Super Moderator Staff Member

    Joined:
    Dec 4, 2013
    Messages:
    1,653
    Likes Received:
    299
    Trophy Points:
    83
    My Device:
    SPro3
    thanks for your input, hope your post will help some peeps out! :)
     
  3. stevae

    stevae New Member

    Joined:
    Jan 16, 2016
    Messages:
    9
    Likes Received:
    1
    Trophy Points:
    3
    My Device:
    SPro4
    you're welcome. i hope so also. thanks for the reply.
     
  4. leeshor

    leeshor Well-Known Member

    Joined:
    Jun 19, 2012
    Messages:
    5,071
    Likes Received:
    877
    Trophy Points:
    113
    Location:
    Norcross, GA
    My Device:
    SPro4
    I've been getting just over 1/2% battery use per hour for since late October and never did install HyperV. No other "hacks" for that mater.
     
  5. Yillbs

    Yillbs Member

    Joined:
    Jan 20, 2016
    Messages:
    84
    Likes Received:
    11
    Trophy Points:
    8
    My Device:
    SPro3
    I'm a bit confused on how you guys are installing these? When I try, it just says the most up to date drivers are already installed for intel 520 graphics. I'm not sure how you can follow the guide wrong, as it's only what, 4 - 5 steps?
     
  6. kundas1

    kundas1 Super Moderator Staff Member

    Joined:
    Dec 4, 2013
    Messages:
    1,653
    Likes Received:
    299
    Trophy Points:
    83
    My Device:
    SPro3
    well you're lucky, ever since I upgraded to win 10 my battery is very bad... but im not going to bother with hacks or fool around with stuff... going to wait till we have an update to fix all this.
     
  7. ppsa

    ppsa New Member

    Joined:
    Dec 22, 2015
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro4
    Where are the new Intel drivers?
     
  8. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,107
    Likes Received:
    1,724
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    Download the zipped version directly from Intel and manually install them...
     
  9. dcoplien

    dcoplien Member

    Joined:
    Jan 23, 2016
    Messages:
    140
    Likes Received:
    14
    Trophy Points:
    18
    Location:
    Wisoconsin
    My Device:
    SPro4
    IntelĀ® Driver Update Utility will check for you. With a Surface Pro 4 it tells me I have no Intel drivers????
     
  10. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,107
    Likes Received:
    1,724
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    The utility will never work as it won't recognize OEM implementations same with attempting to install via the .exe or setup.exe . The only way is manually using the .inf from device manager from the zipped download.
     
  11. bradl79

    bradl79 Member

    Joined:
    Dec 28, 2015
    Messages:
    56
    Likes Received:
    4
    Trophy Points:
    8
    My Device:
    SPro4
    Mine still shows 09,22,15 and I had updated too
     
  12. achabmarco

    achabmarco New Member

    Joined:
    Dec 28, 2015
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro4
    Hi all, this is my experience:
    I just loaded the new intel drivers, (2015-12-22)
    added the script from neowin, setting the max % to 99
    I disabled the wifi during sleep, while I did nothing about the HyperV,
    Then I put to sleep the SP4 at 4PM, with the power cord disconnected; The battery indicator was 94%
    7 hours later the good news is the battery charge left was 90%, but for some reason the machine was not asleep, but probably hibernating. as it took a while to turn back on.
    I set prior to the test the power management to never switch to hibernation mode, both when on battery or connected to the A/C (Control panel/power management/advanced/sleep

    Any ideas if I miss something to set asleep forever the unit to proper test how long it could last sleeping? Maybe enough for a working day, maybe.

    EDIT: Today I repeated the experiment.
    This morning the battery was fully charged, ad 8:30
    12 hours later of sleep (instant wake up) it now works the % left was 78, I occasionally turned it on a couple of times

    22% battery drain in 12 hours is less than 2% per hour! wayyy better than before!
    Thx so much for the tricks, Didn't try yet the hyper-V


    Thankyou!!!

    Marco
     
    Last edited: Jan 25, 2016

Share This Page