Sp2 not charging. Light goes off after 10 secs

Discussion in 'Microsoft Surface Pro 2' started by Angeo_surface, Aug 29, 2016.

  1. Angeo_surface

    Angeo_surface New Member

    Joined:
    Aug 29, 2016
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro2
    Hello to everyone!
    I was incredibly satisfied with my surface up until the point where I had the "plugged in, not charging" problem. I did lots of the suggested things and that gave me 2 more months of use where in one way or another I could finally make it charge. The situation now is that there is no battery left and the charging light goes off after approx 10 secs. I unplug-replug again 10 secs, I press the power button - 10 secs, I unplug-replug the keyboard - 10 secs. During these secs the Windows key vibrates. The trick with the 2 buttons shutdown doesn't help and the 30 secs power button again doesn't help. I dont know what is the cause of the problem and I am really frustrated as the device costed a fortune and I don't understand how Microsoft still cannot resolve this issue. ( I did all that Microsoft suggests). Please some help...

    Thanks in advance!
     
  2. Angeo_surface

    Angeo_surface New Member

    Joined:
    Aug 29, 2016
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro2
  3. JFR

    JFR New Member

    Joined:
    Jul 7, 2014
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Did you tried with another charger?
     
  4. Angeo_surface

    Angeo_surface New Member

    Joined:
    Aug 29, 2016
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro2
    I have tried with a charger of a surface RT and it does charge. The thing is that my charger also works for the RT.... Iam in Ecuador. I bought a non original charger (12v , 2A ) and it charges randomly. I am trying to download the Windows updates and I hope this will solve the issue. What is really annoying is that I have no indication of what the problem is.. the charger seems to be ok. The contacts are clean and clear. Is it a hardware thing or a software? Gr... So much money for this device...
     
  5. jnjroach

    jnjroach Administrator Staff Member

    Joined:
    Nov 9, 2012
    Messages:
    7,107
    Likes Received:
    1,724
    Trophy Points:
    113
    Location:
    Seattle, WA USA
    My Device:
    Surface Book
    You are using a 3rd Party Charger? Or are you using both the original and a 3rd Party?
     
  6. Angeo_surface

    Angeo_surface New Member

    Joined:
    Aug 29, 2016
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro2
    I bought a 3rd party because in Ecuador they don't sell the original. I am travelling around the continent on my bicycle and I can't wait 3 weeks for the original to arrive (especially when I don't know if it's gonna work). I was using the original charger but getting the "plugged in, not charging" message. I found someone who had an RT and used his charger for a bit to see ist it was working. Indeed with the RTs charger it was charging properly but the battery was draining fast. Now I am trying with the 3rd party charger .. it seems to charge when it is shut down. When it's on it charges for some time , then it goes "plugged in, not charging", then charging again and so on... I don't understand honestly
     
  7. JFR

    JFR New Member

    Joined:
    Jul 7, 2014
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Did you cleaned the sp2 connector? Amazon is selling a SP2 charger made by Dragon, seem good quality.
     
  8. Angeo_surface

    Angeo_surface New Member

    Joined:
    Aug 29, 2016
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro2

Share This Page