SP2 waking from sleep mode in Win10

Discussion in 'Windows 10 on Surface Pro 2' started by thilliard, Sep 5, 2015.

  1. thilliard

    thilliard New Member

    Joined:
    Sep 5, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro2
    I just upgraded to Windows 10 and I can't get the tablet to stay in Sleep mode. It wakes up after about 30-60 specs. Anybody else having this problem?
     
  2. benjitek

    benjitek Active Member

    Joined:
    Jan 7, 2014
    Messages:
    622
    Likes Received:
    70
    Trophy Points:
    28
    My Device:
    SPro2
    I had that problem with my SP2 and Windows 8.x. I changed the power button to hibernate instead of sleep and never had a problem after. Being a SSD, power-ups from hibernate are extremely quick. One of the first things I changed after doing a clean install of W10 on my SP2...
     
  3. GoodBytes

    GoodBytes Well-Known Member

    Joined:
    Jan 29, 2014
    Messages:
    1,071
    Likes Received:
    170
    Trophy Points:
    63
    by doing: powercfg -lastwake on the command prompt, you can see what is the last device/program/service that wakes up the computer.
    Probably the system wants to do its maintenance cycle. I recommend to disable sleep, place the device in a cool place, open the Action center of Windows 7/8 (Search for action center on the search box/Cortana), and select "Security & Maintenance", expand Maintenance section, and click on Start and let it run. There is no progress bar sadly, so leave it overnight.

    Once done, restart your system, re-enable sleep, and see if it helps
     
  4. Anony1111

    Anony1111 New Member

    Joined:
    Sep 5, 2015
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro2
    Had the same problem too.

    I configured the power settings to

    1) turn the display off after 5 mins
    2) enter sleep mode after 10mins

    Problem went away.
     
  5. Philtastic

    Philtastic Active Member

    Joined:
    Jan 4, 2014
    Messages:
    381
    Likes Received:
    75
    Trophy Points:
    28
    Location:
    Canada
    My Device:
    SPro4
    I recently got fed up with using hibernate that I went searching for any work arounds and found out that, for whatever reason, the keyboard ends up waking it up immediately. I confirmed this by removing the Type 2 keyboard and then trying to put it to sleep which it didn't automatically wake up from. The work around is to go to device manager, keyboards as well as mice, properties of your keyboards/mice, power management, and disable them from waking the computer up. This allows the SP2 to stay in sleep mode.
     
  6. thilliard

    thilliard New Member

    Joined:
    Sep 5, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro2
    Many thanks for your persistence on this. I tried it and the solution seems to work perfectly.
     
  7. leeshor

    leeshor Well-Known Member

    Joined:
    Jun 19, 2012
    Messages:
    5,071
    Likes Received:
    877
    Trophy Points:
    113
    Location:
    Norcross, GA
    My Device:
    SPro4
    Excellent news!
     
  8. Philtastic

    Philtastic Active Member

    Joined:
    Jan 4, 2014
    Messages:
    381
    Likes Received:
    75
    Trophy Points:
    28
    Location:
    Canada
    My Device:
    SPro4
    The updates from today don't seem to fix the waking from sleep issues. That's unfortunate.
     

Share This Page

Search tags for this page
win10 sleep
,

win10 sleep mode

,
win10 sleep mode wake up
,
win10 surface will not sleep
,
win10 tablet sleep mode