SP3 goes to sleep playing Microsoft Silverlight

Discussion in 'Microsoft Surface Pro 3' started by kozak79, Nov 21, 2014.

  1. kozak79

    kozak79 Active Member

    Joined:
    Nov 15, 2013
    Messages:
    296
    Likes Received:
    60
    Trophy Points:
    28
    My cable company provides an app that uses Microsoft Silverlight to stream cable tv to your computer. When I run it, Windows doesn't detect anything is playing, and goes to sleep while I'm watching the app. Besides setting my SP3 to never sleep, anyone have an idea how to fix this?

    https://www.optimum.net/tv/optimum-app/
     
  2. nipponham

    nipponham Active Member

    Joined:
    Sep 24, 2014
    Messages:
    399
    Likes Received:
    78
    Trophy Points:
    28
    Location:
    Japan
    My Device:
    SPro3
    This is not a Windows/SP3 issue but a programming one. Unfortunately, it boils down to simple coding laziness on the developer's side. There is a specific API they are supposed to use that is supposed to suppress sleep when its processes are active.

    To answer your question, you'll have to manually change the sleep settings whenever you use this app, or use a third party utility that will suppress sleep while the utility is running and then turn it off when you're finished watching tv, (or it will never go to sleep!)
     
  3. Liam2349

    Liam2349 Active Member

    Joined:
    Aug 2, 2014
    Messages:
    884
    Likes Received:
    132
    Trophy Points:
    43
    My Device:
    SPro3
    Use the Windows Mobility Center. Type "mblctr" on Start to find it. From here, activate presentation mode to prevent your computer from sleeping.
     
    kozak79 likes this.

Share This Page

Search tags for this page

how can i stop surface to sleep on optimum app

,

surface going to sleep while watch silverlight