SP3 Static sounds when using earphones

Discussion in 'Microsoft Surface Pro 3' started by Veridis, Sep 19, 2014.

  1. Veridis

    Veridis New Member

    Joined:
    Sep 13, 2014
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Hello everyone, I got a i5/256 version of the SP3 and it is awesome.

    Recently I've been using earphones with it, and I find that if no audio is being played, there will be a "farting" static sound that keeps playing if the earphones are left connected. Anyone else heard this?
     
  2. olimjj

    olimjj Active Member

    Joined:
    Mar 27, 2013
    Messages:
    550
    Likes Received:
    113
    Trophy Points:
    43
    Location:
    Where no man has gone before.
    My Device:
    SPro3
    Farts yes, but not through earphones.
     
  3. Veridis

    Veridis New Member

    Joined:
    Sep 13, 2014
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Thanks for the reply! Hopefully someone else managed to solve this mystery...
     
  4. guymalloc

    guymalloc Member

    Joined:
    Apr 1, 2014
    Messages:
    130
    Likes Received:
    23
    Trophy Points:
    18
    Location:
    Nebraska
    Had the same on my SP1 when I use it with kickstand, typecover and bluetooth mouse. I think its static discharge bleeding out to the earphones. If I'm using it as a tablet in my hands, never have the problem, likewise if it's docked with power connected. I think it just needs to bleed static buildup, better through the earphones than the processor or ssd.....
     
  5. Veridis

    Veridis New Member

    Joined:
    Sep 13, 2014
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    I'm still hearing it.. It the static sounds seems to come a while after audio stops playing.

    Maybe the audio device is being turned off to save power?

    I've been trying to Google more on this issue and it seems there isn't many people talking about this.
     
  6. khit

    khit New Member

    Joined:
    Jul 13, 2014
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    I too hear this now on the replacement SP3 I just received... it'll be a small popping coming from the earphones. I tend to notice it more when I'm moving the track pad or about to press a key. It's slight but it's there and I'm not sure how to solve it.
     
  7. Veridis

    Veridis New Member

    Joined:
    Sep 13, 2014
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    I tried testing on the SP3 I bought for my mother. I played a video on earphones, paused it, and waited for 1min. The popping sound appeared.
     
  8. wynand32

    wynand32 Active Member

    Joined:
    Jun 24, 2014
    Messages:
    841
    Likes Received:
    174
    Trophy Points:
    43
    Location:
    Oak Park, CA
    My Device:
    SPro3
    I had that on mine as well. I updated to the latest Realtek drivers and the issue's mostly gone away.
     
  9. Veridis

    Veridis New Member

    Joined:
    Sep 13, 2014
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    I tried updating to HD Realtek drivers by first going to Device Manager and uninstalling the driver, then installing the Realtek drivers but the popping is still there.

    I did this multiple times to be sure. Am I missing something?
     
    Last edited: Sep 25, 2014
  10. fifl

    fifl New Member

    Joined:
    Jan 7, 2014
    Messages:
    20
    Likes Received:
    0
    Trophy Points:
    1
    I have had that sound on all my computers, so I bought earphones with audiocontrol on them. Then I just take the audio level down to the lowest on the earphones and a little higher on the computer, solves the problem every time.
     
  11. khit

    khit New Member

    Joined:
    Jul 13, 2014
    Messages:
    16
    Likes Received:
    0
    Trophy Points:
    1
    only issue with that approach is that my first surface pro 3 did not have any audio popping at all, neither does my SP1. I did a refresh last week to see if it would help and no dice.
     
  12. wynand32

    wynand32 Active Member

    Joined:
    Jun 24, 2014
    Messages:
    841
    Likes Received:
    174
    Trophy Points:
    43
    Location:
    Oak Park, CA
    My Device:
    SPro3
    Not really sure. Might be that we had different issues that just seemed the same, which is why the newer Realtek drivers fixed my issue and not yours.
     

Share This Page

Search tags for this page

headphones surface 2 static

,
hearing static sounds on surface 3
,
how to fix static sound when using headphones surface
,
static coming from headphone jack on surface 3
,
static on hello pro earphones
,
static sound surface 3
,

surface 3 sound static

,
surface 3 static sound
,
surface pro bluetooth static
,
there is static sound from surface pro 3