SP4 conntected to external Display, not possible to get a proper picture on both

Discussion in 'Microsoft Surface Pro 4' started by SweetPete, Nov 16, 2015.

  1. SweetPete

    SweetPete New Member

    Joined:
    Nov 16, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro4
    I'm using a Dell2412m connected to the new dock with a mini dp to dp cable. When I plug in the dock while the sp4 is running the external display has blurry text. When I boot the sp4 while connected to the dock, the sp4 picture is messed up (like this messed up to normal comparison: Imgur: The most awesome images on the Internet ). I played with scaling (external is set to 100%, sp4 to 200%) and Cleartype Text without any success. Could anyone share some insight on what the reason for this is? Is it just a matter of waiting for a newer graphic driver that will fix this or is this likely a permanent issue?
     
  2. bsnguy

    bsnguy Member

    Joined:
    Oct 26, 2015
    Messages:
    40
    Likes Received:
    2
    Trophy Points:
    8
    My Device:
    SPro4
    I run the same monitor with no issues. Some tings to check:

    1) I presume you can use the same monitor/cable with another computer? If you can, then we know it's something in the SP4 setting/hardware.

    2) Do you have a second cable you could try?

    3) What is your display resolution set to on the 2412? Make sure it's set to 1920x1200
     
  3. SweetPete

    SweetPete New Member

    Joined:
    Nov 16, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro4
    Didn't even think that the cable might be the cause. Sadly I don't have another cable or device that outputs to mini dp. I ordered a new cable, it should arrive on Wednesday and I will report back with results. Thank your very much for your input.

    PS: Resolution was set to 1920x1200 yes.
     
  4. bsnguy

    bsnguy Member

    Joined:
    Oct 26, 2015
    Messages:
    40
    Likes Received:
    2
    Trophy Points:
    8
    My Device:
    SPro4
    I think you mentioned "the dock." Have you tried connecting directly to the SP4? Same or different issue if you do? I've heard the dock has some video issues...
     
  5. SweetPete

    SweetPete New Member

    Joined:
    Nov 16, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro4
    Yea I just tried that (don't ask me why I didn't think of it before - I have no idea). When I plug in the cable while the surface is running, both screens turn black, Surface screen comes back as soon as I unplug the cable. When I try to boot with the cable plugged in, there is no picture on either screen or it simple doesn't start up - I can't tell. This is the cable I am using: Delock Products Delock Cable Mini Displayport 1.2 male > Displayport male 4K 2.0 m -
    It cost only 8 Euros, I was of the opinion with digital signal transfer it either works or it doesn't and there is no better quality to be gained by more expensive cables, like with analog signal transfers.
     
  6. bsnguy

    bsnguy Member

    Joined:
    Oct 26, 2015
    Messages:
    40
    Likes Received:
    2
    Trophy Points:
    8
    My Device:
    SPro4
    I agree, in general, about the cables. But I have had a bad one (in fact, it was good and then stopped working after a few months). So hope it's that! Otherwise, this does seem odd.
     
  7. SweetPete

    SweetPete New Member

    Joined:
    Nov 16, 2015
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    My Device:
    SPro4
    Short update: got the new cable and there is no distortion on the sp4 anymore when displaying on both screens and after docking/undocking. The dell screen is still a little more blurry than in single screen mode and I'm still not able to use an external display without the dock, the sp4 just doesn't recognise the screen. Thanks bsnguy for the help, I wouldn't have thought that the cable makes that much of a difference for display port. I'm going to try another one and see if that gets different results :)
     

Share This Page