Solved SP4 Still Active In Sleep

Discussion in 'Microsoft Surface Pro 4' started by Philtastic, Oct 30, 2015.

  1. Philtastic

    Philtastic Active Member

    Joined:
    Jan 4, 2014
    Messages:
    381
    Likes Received:
    75
    Trophy Points:
    28
    Location:
    Canada
    My Device:
    SPro4
    In the week that I've had the SP4, it's happened twice where I'd put my device to sleep, put it into my bag, commute, and then pull it out where the unit is pretty warm with a good chunk of battery missing (8-12% over my half hour commute). The device is definitely still asleep as the screen doesn't turn on when I touch the screen as would be the case in a screen-off-but-device-still-on scenario. Anyone else experienced this?

    A bit more context that might be informative: from habit with my previous SP2, I put the device to sleep, disconnected the charger which woke up the SP4, and then hit the power button to put it back to sleep. I wonder if that order of events screws up the sleep state. (Edit: It doesn't seem to make a difference)
     
    Last edited: Nov 1, 2015
  2. DocACE911

    DocACE911 Member

    Joined:
    Nov 16, 2014
    Messages:
    47
    Likes Received:
    2
    Trophy Points:
    8
    Having same problem with new m3.

    On my SP3 was having this problem - caused by a audio driver (RAZER 5.1 surround headphones) that was installed.

    My SP3 has windows 8.1 and works fine. This new one is getting 4 hour battery life and not going into connected standby
     
  3. leeshor

    leeshor Well-Known Member

    Joined:
    Jun 19, 2012
    Messages:
    5,071
    Likes Received:
    877
    Trophy Points:
    113
    Location:
    Norcross, GA
    My Device:
    SPro4
    Interesting. Can you tell if it did anything? I have mine set to turn off WiFi when sleeping. I wonder if that would make any difference.
     
  4. DocACE911

    DocACE911 Member

    Joined:
    Nov 16, 2014
    Messages:
    47
    Likes Received:
    2
    Trophy Points:
    8
    Turning off wifi defeats the beauty of connected sleep!!!

    You know, this thing needs to "just work" a bit better out of the box.
     
  5. leeshor

    leeshor Well-Known Member

    Joined:
    Jun 19, 2012
    Messages:
    5,071
    Likes Received:
    877
    Trophy Points:
    113
    Location:
    Norcross, GA
    My Device:
    SPro4
    Yes it does, but I don't have any reason to be connected in sleep. I'm after getting the best battery life possible and not turn off anything I need. That's one thing I don't need.
     
  6. Philtastic

    Philtastic Active Member

    Joined:
    Jan 4, 2014
    Messages:
    381
    Likes Received:
    75
    Trophy Points:
    28
    Location:
    Canada
    My Device:
    SPro4
    I considered turning off the wifi while asleep to see if that was the problem (I obviously leave my home wifi when I go out the door) but, as stated byDocACEo911, it really should just work without me having to troubleshoot a bunch of settings.

    I'm not sure of a good way to check what it was doing at the time. Any ideas on how to track system usage?
     
  7. leeshor

    leeshor Well-Known Member

    Joined:
    Jun 19, 2012
    Messages:
    5,071
    Likes Received:
    877
    Trophy Points:
    113
    Location:
    Norcross, GA
    My Device:
    SPro4
    Allow me to put it this way. With all the tuning I have done I lose 5% battery sleeping 12 hours. I'm not sure I can do better but I'm going to try. ;)
     
  8. Migi

    Migi Member

    Joined:
    Oct 11, 2015
    Messages:
    52
    Likes Received:
    2
    Trophy Points:
    8
    My Device:
    None
    You would think a premium device like would not have basic issues like this. You never hear about Macs not going to sleep mode.

    OTOH, if they can't get "Connected Standby" to work properly, just eliminate it. This is how Apple works, by KISS(Keep it Simple Stupid) approach.
     
  9. Philtastic

    Philtastic Active Member

    Joined:
    Jan 4, 2014
    Messages:
    381
    Likes Received:
    75
    Trophy Points:
    28
    Location:
    Canada
    My Device:
    SPro4
    Yeah, so there really is something wrong with sleep on the SP4. Here's my battery report that I just made (do note that the time stamp is wrong stating that I made the report at 8:55 pm when I just made it at 10:15 pm). My SP4 was supposed to be sleeping in my bag from 6:49 pm onward where it says that it went into Connected standby at 87% battery. Over the next 3.5 hours, the battery went down to 61%, a loss of 26% or 7.4% per hour. In this case, before I put it into my bag, I unplugged it first and then put it to sleep.

    I'm going to try disabling connected standby to see if that helps things. Kind of disappointed in this now that I'm back to troubleshooting problems that a device like this shouldn't have.
    [​IMG]
     
  10. callihan_44

    callihan_44 Member

    Joined:
    Oct 15, 2013
    Messages:
    97
    Likes Received:
    18
    Trophy Points:
    8
    If you depend on max battery life why not just shut the tablet off ? With Today'ssdS Boot time is pretty fast
     
  11. Philtastic

    Philtastic Active Member

    Joined:
    Jan 4, 2014
    Messages:
    381
    Likes Received:
    75
    Trophy Points:
    28
    Location:
    Canada
    My Device:
    SPro4
    I don't necessarily need max battery life but I'm pretty sure that draining 7-8% battery per hour in sleep is unusual. In fact, if we assume that the SP4 can get 8 hours of battery while active, 7-8% is not far from the predicted 12% per hour while active.

    My SP2 would drain maybe 2% per hour in sleep... but would go to hibernate after 1 hour which isn't the case with the SP4.
     
  12. Philtastic

    Philtastic Active Member

    Joined:
    Jan 4, 2014
    Messages:
    381
    Likes Received:
    75
    Trophy Points:
    28
    Location:
    Canada
    My Device:
    SPro4
    With wifi connection off for when on battery, it burned through 9% in an hour while apparently asleep. I still had wifi connection on when plugged in, however. I have now turned that off as well. This is pretty ridiculous.

    And no, I don't think changing the registry and disabling sleep is a valid solution to this problem.
     
    Last edited: Oct 31, 2015

Share This Page

Search tags for this page

sp4 sleepstudy

,
surface pro 4 active cpu sleep